Feature Definition Managerへようこそ

Feature Definition Managerのオンラインヘルプへようこそ。Feature Definition Managerは、特徴定義(プロパティ)の作成および管理を行うためのソフトウェアツールです特徴定義は現場装置に簡単にアップロードできるので、測量技師はそれらを現場で遭遇するオブジェクトに割り当てることができます。 その後で、オフィス測量処理ソフトウェアを使用し、特徴およびその他の記録された測量データを処理して、その他のシステム(CADパッケージなど)にエクスポートできます。

Feature Definition Managerの概要

"特徴"は、測量技師が、測量データを収集する際に観測および記録する自然物や人工物を表します。 例としては、樹木、フェンス、標識、電柱、ビルなどがあります。 観測オブジェクトの特徴情報を容易かつ効果的に記録するために、測量技師は、現場装置を使用して、特徴の定義済みライブラリ(特徴定義)から選択して、適切な定義の一意の特徴コードをオブジェクトに割り当てることができます。 これにより、特徴定義に関連付けられたすべてのプロパティ(特徴の名前とコード、画像ソフトウェア表示でのオブジェクトの表現に使用されるシンボル、およびその他のカスタム属性など)がオブジェクトに割り当てられます。

特徴には2つの基本的なタイプがあり、それぞれのタイプは異なるタイプの特徴定義によって表されます。

  • ポイントの特徴は、樹木や電柱など、1つの特徴を識別するために使用します。 エクスプローラペイン内では、ポイントの特徴定義は、 [image] アイコンで表されます。
  • ライン特徴は、フェンスや道などのラインを定義する2つ以上のポイントで構成されます。 エクスプローラペイン内では、ライン特徴定義は、 [image] アイコンで表されます。 ライン特徴には、線状の特徴を詳細に定義するライン制御コードが含まれることがあります(ポイント間でのライン、曲線、円曲線の追加など)。

関連項目

Feature Definition Managerのワークフロー

インターフェースの概要


Feature Definition Managerのワークフロー

次の手順は、Feature Definition Managerを操作する際の高いレベルのワークフローを示します。 詳細については、該当するリンクをクリックしてください。

  1. 特徴定義(.fxl)ファイルを開くか作成します。または、特徴定義データをダウンロードまたはインポートします。
  2. 特徴定義(.fxl)ファイルプロパティを入力および編集します。
  3. 特徴定義カテゴリを作成および編集します。
  4. 特徴定義を作成および編集します。
  5. 特徴定義に使用するシンボルを作成および編集します。
  6. ライン特徴定義に使用するオフセットラインを作成および編集します。
  7. 特徴定義の属性を追加および編集します。
  8. ライン制御コードを作成および編集します。
  9. 特徴定義コードおよびライン制御コードのグループを作成します。
  10. 特徴定義(.fxl)ファイルを保存します。
  11. ファイルのエクスポート、または現場装置へのアップロードを行います。

関連項目

Feature Definition Managerへようこそ

インターフェースの概要


インターフェースの概要

特徴定義マネージャのユーザインターフェースには、以下の共通要素が含まれています。

ユーザインターフェース

メニューバー

すべてのコマンドにアクセスできます。 以下の操作を行うことができます。

  • メニュー項目をクリックする。
  • [Alt]キーとメニュー項目の下線付き文字(ニーモニック)キーを押します 次に、別のニーモニックキーを押すか、上下の矢印キーを押し、[Enter]キーを押してメニューを選択できます。

ツールバー

アイコンを使用して、最も一般的に使用されるコマンドにアクセスできます。

ツールバーには、特徴コードを入力できる検索ボックスも含まれています。 [Enter]キーを押すと、エクスプローラペインで該当する特徴が選択されます。

エクスプローラペイン

各ファイルのカテゴリ、特徴、ライン制御コード、およびグループがツリー形式で表示されます。 エクスプローラペインでは、ファイル内のエレメントをすばやく選択、移動、および整理できます。

エクスプローラペインでは、以下の操作を行うことができます。

  • 複数のファイルを開く。
  • 右クリックしてコンテキストメニューを使用し、新しいファイル、カテゴリ、特徴、およびグループを作成する。

プロパティおよび属性ペイン

選択したファイル、カテゴリ、特徴、グループ、およびライン制御コードのプロパティが表示され、これらのプロパティを編集できます。

画像表示

画像表示で特徴シンボルおよび注釈がどのように表示されるかが示され、注釈を選択および移動できます。

注記: 画像表示をパンするには、マウスの中央のボタンをクリックしてドラッグします。 ズームインまたはズームアウトするには、マウスホイールを回転させます。

ステータスバー

現在のカテゴリと特徴名、および画像表示でのカーソル位置が表示されます。

関連項目

特徴定義マネージャへようこそ

特徴定義マネージャのワークフロー


ヘルプの表示

このヘルプシステムでは、さまざまな方法で必要な情報を検索できます。

オプション
目次 | このタブをクリックすると、すべてのヘルプトピックがツリー構造で表示されます。 表示する章またはトピックをクリックします。
検索 | 検索ボックスにキーワードを入力します。 検索をクリックすると、そのキーワードを含むヘルプトピックが検索されます。 検索結果でトピックを選択し、表示をクリックして、そのトピックを表示します。 検索したキーワードが各ヘルプトピックでハイライトされます。 下の「検索ハイライトの切り替え」オプションを参照してください。
非表示/表示 | 目次および検索タブの表示と非表示を切り替えます。
戻る | クリックすると、以前のトピックが表示されます。
印刷 | クリックすると、印刷ダイアログが表示されます。 選択したトピックだけを印刷するか、見出しとすべてのサブトピックを印刷するかを指定するオプションを選択します。
オプションメニュー
停止 | 検索を停止する場合にクリックします。
更新 | クリックすると、現在のページの表示がリセットされます。
インターネットオプション | クリックすると、インターネットオプションダイアログが表示されます。このダイアログでは、セキュリティ、プライバシー、コンテンツ、接続、プログラム、およびインターネットに関するその他の設定を行うことができます。
検索ハイライト オン/オフ | クリックすると、検索したトピック内に存在するキーワードの各インスタンスのハイライトが有効または無効になります。

関連項目

特徴定義マネージャへようこそ


フィードバックの送信

弊社ではユーザーにとってできる限り実用的なドキュメントを提供するよう、常に努力しています。 ヘルプ、リリースノート、チュートリアル、またはワークフローガイドの向上に役立つコメントまたはフィードバックを以下のアドレスまで送信してください。
OSG_Documentation@Trimble.com

お送り頂いたコメントおよびフィードバックの所有権は、Trimble Navigation Limitedに帰属します。


特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルには、特徴定義マネージャのネイティブフォーマットで編成された以下のタイプの情報が格納されています。

  • 特徴定義カテゴリ
  • 特徴定義
  • 特徴属性
  • ライン制御コード
  • 特徴定義/ライン制御グループ
  • シンボルおよびラインスタイル

関連項目

特徴定義(.fxl)ファイルの作成

特徴定義(.fxl)ファイルを開く

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルプロパティ

特徴定義(.fxl)ファイルテンプレートの作成

特徴定義(.fxl)ファイルの保存


特徴定義(.fxl)ファイルの作成

新しい特徴定義(.fxl)ファイルを作成するには:

  1. 以下のいずれかの操作を行います。
    • ファイル > 新規ファイルをクリックします。
    • ツールバーの [image] アイコンをクリックします。

    エクスプローラペインに「新しいファイル」という名前の新規フォルダアイコンが表示され、ファイルのプロパティペインが表示されます。

  2. 必要なボックスをクリックして値を編集します。

    手順の詳細については、「ファイルのプロパティ」を参照してください。

    注記: 最大長をゼロ(0)に設定すると、文字数の制限がなくなります。

  3. 作業が終了したら、以下のいずれかの操作を行います。
    • ファイル > 保存を選択します。
    • ツールバーの [image] アイコンをクリックします。

    保存ダイアログが表示されます。

  4. 保存ダイアログで、ファイルの名前を入力し、ファイルタイプを選択して、ファイルを保存する場所を選択します。 OKをクリックします。

エクスプローラペインの新しいファイルが、指定したパスおよびファイル名で置き換えられます。

関連項目

特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルを開く

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルプロパティ

特徴定義(.fxl)ファイルテンプレートの作成

特徴定義(.fxl)ファイルの保存


特徴定義(.fxl)ファイルを開く

既存の特徴定義(.fxl)ファイルを開くには:

  1. 以下のいずれかの操作を行います。
    • ファイル> 開くを選択します。
    • 標準ツールバーの [image] アイコンをクリックします。

    ファイルを開くダイアログボックスが表示されます。

  2. ファイルを開くダイアログで、開くファイルを指定してOKをクリックします。

    エクスプローラペインにファイルアイコンが表示され、ファイルのプロパティペインが表示されます。

    注記:
    - Feature Definition Managerに付属するサンプルデータFXLファイルは、Program Filesフォルダ内のアプリケーションサブフォルダにインストールされます。 しかし、ソフトウェアを起動すると、2番目のバージョンが(マイ)ドキュメントフォルダ内のサブフォルダに作成されます。このバージョンは、ファイルメニューから開くことができます。 Program Filesフォルダ内のアプリケーションサブフォルダに保存されている元のバージョンではなく、新しく作成された2番目のバージョンのファイルを使用することをお勧めします。
    - Feature Definition Managerでは、既定によりすべての特徴定義(.fxl)ファイルが最新バージョンのフォーマットで開かれ、保存されます。このフォーマットは、Trimble AccessおよびSurvey Controllerバージョン12.40以降とご完成があります。

関連項目

特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルの作成

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルプロパティ

特徴定義(.fxl)ファイルテンプレートの作成

特徴定義(.fxl)ファイルの保存


FCLファイルからFXLファイルへの変換

FCLファイルをFXLファイルに変換するには

  1. ファイル > ファイルの変換を選択します。 ファイルの変換ダイアログが表示されます。
  2. 変換する.fclファイルのファイル名およびパスをソースの特徴および属性ライブラリ(.fcl)ファイルの選択ボックスに入力するか、 [image] ボタンをクリックして.fclファイルを参照します。
  3. ターゲットの.fxlファイルのファイル名およびパスをターゲット特徴定義(.fxl)ファイルの定義ボックスに入力するか、 [image] ボタンをクリックして.fxlファイルを参照します。
  4. .fclファイルで使用されている言語をソース(.fcl)ファイルの言語の選択リストで選択します。
  5. .fclファイルから変換する.fxlのバージョンを選択します。
  6. OKをクリックします。

    新しく作成された.fxlファイルのアイコンがプロジェクトエクスプローラペインに表示されます。


特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルプロパティを入力または編集するには:

  1. エクスプローラペインで、目的のファイルを選択します。
  2. 以下のいずれかの操作を行います。
    • ファイル > プロパティを選択します。
    • ツールバーの [image] アイコンをクリックします。

    ファイルのプロパティペインが表示されます。

  3. 必要なボックスをクリックして値を編集します。

    手順の詳細については、「ファイルのプロパティ」を参照してください。

    注記: 最大長をゼロ(0)に設定すると、文字数の制限がなくなります。

  4. 作業が終了したら、以下のいずれかの操作を行います。
    • ファイル > 保存を選択します。
    • ツールバーの [image] アイコンをクリックします。

    新しいファイルでプロパティを初めて設定する場合は、保存ダイアログが表示されます。 保存ダイアログで、ファイルの名前を入力し、ファイルタイプを選択して、ファイルを保存する場所を選択します。 OKをクリックします。

関連項目

特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルの作成

特徴定義(.fxl)ファイルを開く

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティ

特徴定義(.fxl)ファイルテンプレートの作成

特徴定義(.fxl)ファイルの保存


特徴定義(.fxl)ファイルプロパティ

これらのオプションを使用して、作成者、説明、特徴コードが数値のみであるかどうか、および特定のフィールドの最大長を指定します。 これらのオプションは、ファイルのプロパティパネルに表示されます。

オプション
作成者 | ファイルの作成者の名前を入力します。
説明 | ファイルに関する追加の情報を入力します。
作成日 | ファイルが最初に作成された日付(読み取り専用)が表示されます。
変更日 | ファイルが最後に保存された日付(読み取り専用)が表示されます。
特徴コードに数値だけを使用する | いいえ - アルファベットと数値のコードを許可する場合に選択します。 はい - コードを数値のみに制限する場合に選択します。
属性名の最大長 | 属性の名前ボックスに入力できる最大文字数を指定する値を入力します。 注記: 最大長をゼロ(0)に設定すると、文字数の制限がなくなります。
カテゴリ名の最大長 | カテゴリの名前ボックスに入力できる最大文字数を指定する値を入力します。
特徴名の最大長 | 特徴の名前ボックスに入力できる最大文字数を指定する値を入力します。
特徴コードの最大長 | すべての特徴コードの名前ボックスに入力できる最大文字数を入力します。
コード / グループの最大数 | 各グループで入力できる特徴コードまたは制御コードの最大数を入力します。 これは使用する現場装置のタイプによって決まります。

関連項目

特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルの作成

特徴定義(.fxl)ファイルを開く

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルテンプレートの作成

特徴定義(.fxl)ファイルの保存


特徴定義(.fxl)ファイルテンプレートの作成

頻繁に使用する特徴データを含むテンプレートを作成できます。 テンプレートを作成すると、時間を節約することができるだけでなく、複数のプロジェクト間での一貫性を維持できます。

テンプレートファイルを作成するには

  1. 作成するテンプレートに類似した既存のファイルを開くか、新しいファイルを作成します。

    注記: 以下の手順の詳細については、適切なヘルプトピックを参照してください。

  2. ファイルプロパティを必要に応じて設定します。
  3. 必要に応じて、カテゴリ、特徴、属性、制御コード、およびグループを作成、編集、および削除します。
  4. 必要に応じて、注釈およびシンボルを作成、編集、および削除します。
  5. ファイル > 名前を付けて保存を選択します。 名前を付けて保存ダイアログが表示されます。
  6. 名前を付けて保存ダイアログで次の操作を行います。
    1. ファイルの名前を入力します。
    2. ファイルタイプを選択します。
    3. ファイルの保存場所を選択します。
    4. OKをクリックします。

関連項目

特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルの作成

特徴定義(.fxl)ファイルを開く

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルプロパティ

特徴定義(.fxl)ファイルの保存


特徴定義(.fxl)ファイルの保存

特徴定義(.fxl)ファイルは、早い段階から頻繁に保存してください。

警告: 変更は保存するまでファイルに保存されません。

変更定義(.fxl)ファイルを保存するには:

  1. 以下のいずれかの操作を行います。
    • ファイル > 保存を選択します。
    • ツールバーの [image] アイコンをクリックします。

    そのファイルが以前に保存されている場合は、ファイルを保存する際にダイアログは表示されません。 そのファイルを以前に保存したことがない場合は、保存ダイアログが表示されます。

  2. 保存ダイアログが表示された場合は、次の操作を行います。
    1. ファイルの名前を入力します。
    2. ファイルタイプを選択します。
    3. ファイルの保存場所を選択します。
    4. OKをクリックします。 エクスプローラペインの新しいファイルが、指定したパスおよびファイル名で置き換えられます。

特徴定義(.fxl)ファイルを新しい名前で保存するには:

  1. ファイル > 名前を付けて保存を選択します。 名前を付けて保存ダイアログが表示されます。
  2. 名前を付けて保存ダイアログで次の操作を行います。
    1. ファイルの名前を入力します。
    2. ファイルタイプを選択します。
    3. ファイルの保存場所を選択します。
    4. OKをクリックします。 エクスプローラペインに新しいファイル名が表示されます。

関連項目

特徴定義(.fxl)ファイルの管理

特徴定義(.fxl)ファイルの作成

特徴定義(.fxl)ファイルを開く

FCLファイルからFXLファイルへの変換

特徴定義(.fxl)ファイルプロパティの入力および編集

特徴定義(.fxl)ファイルプロパティ

特徴定義(.fxl)ファイルテンプレートの作成


特徴定義データのダウンロードおよびインポート

現場装置から特徴定義データを直接"ダウンロード"することや、ファイルに保存された特徴定義データを"インポート"することができます。

注記: データをインポートまたはダウンロードするには、ファイルが開かれている必要があります。 インポートおよびダウンロードされたデータは、現在のファイルに配置されます。

現場装置から特徴定義データをダウンロードするには:

  1. 現場装置をコンピュータに接続します。
  2. ファイル > インポートをクリックします。 ファイルのインポートダイアログボックスが表示されます。
  3. 装置からダウンロードをクリックします。
  4. 装置名のリストで現場装置を選択します。
  5. アプリケーションのリストでプログラムを選択します。
  6. OKをクリックします。 ダウンロードされたデータがエクスプローラペインのファイルに表示されます。

ファイルから特徴定義データをインポートするには:

  1. ファイル > インポートをクリックします。 ファイルのインポートダイアログボックスが表示されます。
  2. ファイルからインポートをクリックします。
  3. ソースファイルボックスにファイルのパスと名前を入力するか、 [image] ボタンをクリックして、必要なファイルにナビゲートします。
  4. アプリケーションのリストでプログラムを選択します。
  5. OKをクリックします。 インポートされたデータがエクスプローラペインのファイルに表示されます。

関連項目

インポートおよびダウンロードオプション

インポートおよびエクスポートフォーマット

データディクショナリファイル(.ddf)のインポート


インポートおよびダウンロードオプション

これらのオプションを使用して、別のアプリケーションまたは現場装置から外部データをインポートします。 これらのオプションは、ファイルのインポートダイアログで使用できます。

特徴定義マネージャのネイティブファイル形式は.fxlで、特徴の定義を効率的に保存および整理できます。 マネージャのインポートユーティリティでは、このファイル形式をその他の多くの形式との互換形式にすることができます。

オプション
ソースファイル | インポートするファイルのパスおよび名前を指定するか、 [image] ボタンをクリックしてファイルにナビゲートします。
ファイルタイプ | 選択したファイルのフォーマットが表示されます。
ファイルからインポート | クリックして、ローカルまたはネットワークドライブに保存されているファイルを選択します。
装置からダウンロード | クリックして、接続されている現場装置に保存されているファイルを選択します。
装置名 | 接続している現場装置の名前が表示されます。
アプリケーション | 特徴ファイルを使用する現場ソフトウェアを選択します。

関連項目

特徴定義データのダウンロードおよびインポート

インポートおよびエクスポートフォーマット

データディクショナリファイル(.ddf)のインポート


インポートおよびエクスポートフォーマット

特徴定義マネージャを使用すると、さまざまなソフトウェアプログラムとの間で以下のフォーマットでのインポートおよびエクスポートを行うことができます。

インポート | ファイルフォーマット | エクスポート
 | .fal - 特徴および属性ライブラリファイル |
 | .ddf - データディクショナリファイル |
 | .csv - シンプルテキストファイル |
 | .lst - ニコンコードリストファイル |
 | .xml - ジオリファレンスファイル |

関連項目

特徴定義データのダウンロードおよびインポート

データディクショナリファイル(.ddf)のインポート

インポートおよびダウンロードオプション


データディクショナリファイル(.ddf)のインポート

Trimble GPS Pathfinderソフトウェアを使用している場合、データディクショナリファイル(.ddf)をデータディクショナリエディタからインポートできます。 この形式で特徴データをインポートした場合、特徴定義マネージャで属性を再作成する必要はありません。

データディクショナリファイルがインポートされると、すべてのラインおよびエリア特徴はポイント特徴に変換されますが、属性定義は変更されずに維持されます。

同じ名前の.ddf特徴が特徴定義ライブラリに既に存在している場合は、以下の処理が行われます。

  • .ddfバージョンの属性によって既存の特徴の属性が上書きされます。
  • .ddfファイルには該当する情報が含まれていないので、既存の特徴のポイントスタイル、ラインスタイル、および注釈テンプレートは維持されます。

特徴ライブラリに.ddf特徴が存在しない場合、ポイントスタイルが定義されていないので、.ddf特徴は疑問符付きで表示されます。

それ以外の場合は、データディクショナリファイルからインポートされた特徴は、特徴定義マネージャで作成された特徴と基本的に同じです。

関連項目

特徴定義データのダウンロードおよびインポート

インポートおよびダウンロードオプション

インポートおよびエクスポートフォーマット


ジオリファレンスファイル(.xml)のインポート

ジオデータベース(.xml)から特徴定義をインポートする際は、以下の点に注意してください。

  • ジオデータベースファイルは、特徴定義コードをサポートしません。 ジオデータベースファイルをFeature Definition Managerにインポートするとき、定義名が定義コードに使用されます。 名前またはコードはインポート後に変更できます。
  • ジオデータベースファイルはスペースが含まれる特徴定義名をサポートしません。 ジオデータベースファイルをFeature Definition Managerにインポートするとき、定義名およびコードにはスペースの代わりにアンダースコアが含まれます。 名前とコードはインポート後に編集できます。
  • ジオデータベースファイルはカテゴリをサポートしません。 ジオデータベースファイルをFeature Definition Managerにインポートすると、インポートされたすべての特徴定義はその他カテゴリに割り当てられます。 必要な場合は、インポート後に特徴定義を新しいカテゴリまたは既存のカテゴリに分類できます。
  • ジオデータベースファイルは、既定の属性値またはラインおよびシンボルをサポートしません。 必要な場合は、インポート後にこれらのプロパティを追加できます。

関連項目

特徴定義データのダウンロードおよびインポート

インポートおよびダウンロードオプション

インポートおよびエクスポートフォーマット


特徴定義カテゴリの操作

カテゴリを使用して、特徴定義を類似の定義のセットにまとめることができます。 カテゴリを使用すると、現場作業員は、現場データの収集を準備する際に、特定の種類の作業に必要な特徴定義だけをすばやく選択できます。

エクスプローラペインでカテゴリを選択すると、そのカテゴリに含まれる特徴定義のリストがメインウィンドウに表示されます。

関連項目

特徴定義カテゴリの作成と編集


特徴定義カテゴリの作成と編集

特徴定義カテゴリを作成するには:

  1. エクスプローラペインで、新しいカテゴリを追加するファイルを右クリックして、新規作成 > 新しいカテゴリを選択します。 新しいカテゴリの名前ペインが表示されます。
  2. 名前ボックスに新しいカテゴリの名前を入力します。
  3. エクスプローラペイン内の任意の場所をクリックします。 新しいカテゴリがエクスプローラペインに表示されます。

特徴定義カテゴリ名を編集するには:

  1. エクスプローラペインで、編集するカテゴリの名前をクリックします。 カテゴリの名前ペインが表示されます。
  2. 名前ボックスに新しいカテゴリ名を入力します。
  3. エクスプローラペイン内の任意の場所をクリックします。 名前が変更されたカテゴリがエクスプローラペインに表示されます。

関連項目

特徴定義カテゴリの操作


特徴定義の操作

特徴定義は、現場に存在する可能性のある特徴のタイプ(歩道や電柱など)を表すために使用します。 特徴定義マネージャには、定義済みの特徴定義のセットが含まれていて、独自の特徴定義ライブラリを構築する際の開始ポイントとして使用できます。

同じ名前およびコードの特徴定義を含む複数のファイルを同時に開くことが可能ですが、ファイル内の個々の特徴定義には一意の名前とコードが必要です。

ツールバーには、特徴定義、制御コード、またはグループの名前を入力できる検索ボックスもあります。 [Enter]キーを押すと、エクスプローラペインで該当する名前が選択されます。

2つのタイプの特徴定義が使用可能です。

  • ポイントの特徴は、樹木や電柱など、1つの特徴を識別するために使用します。 エクスプローラペイン内では、ポイントの特徴定義は、 [image] アイコンで表されます。
  • ライン特徴は、フェンスや道などのラインを定義する2つ以上のポイントで構成されます。 エクスプローラペイン内では、ライン特徴定義は、 [image] アイコンで表されます。 ライン特徴には、線状の特徴を詳細に定義するライン制御コードが含まれることがあります(ポイント間でのライン、曲線、円曲線の追加など)。

関連項目

特徴定義の作成および編集

特徴定義オプション


特徴定義の作成および編集

特徴定義を作成するには

  1. エクスプローラペインで、新しい特徴を追加するファイルをクリックします。
  2. 以下のいずれかの操作を行います。
    • 編集 > 新規作成 > 新しい特徴定義を選択します。
    • 新規作成ツールバーの [image] アイコンをクリックします。

    新しい特徴定義ダイアログが表示されます。

    注記: 以下の手順の詳細については、「特徴定義オプション」を参照してください。

  3. 名前およびコードボックスに適切な値を入力します。
  4. 適切なオプションをカテゴリ、タイプ、色、およびレイヤーリストから選択します。
  5. 必要に応じて面に含める、面のブレークライン、または方向を反転オプションをオンにします (面のブレークラインおよび方向を反転オプションは、ライン特徴定義を作成する場合にのみ使用可能です)。
  6. 作業が終了したら、OKをクリックします。 エクスプローラペインで選択したカテゴリの下に新しい特徴定義アイコンが追加されます。

既存の特徴定義を編集するには:

  1. エクスプローラペインで、編集する特徴定義の名前をクリックします。 特徴定義プロパティペインが表示されます。
  2. 特徴定義プロパティペインのボックスをクリックして、プロパティを編集します。 詳細については、「特徴定義オプション」を参照してください。
  3. TABキーを押すか、エクスプローラペインで別の項目を選択して、変更を適用します。

関連項目

特徴定義の操作

特徴定義オプション


特徴定義オプション

これらのオプションを使用して、特徴定義のプロパティを定義します。 これらのオプションは、新しい特徴定義ダイアログおよび特徴定義プロパティペインで使用できます。

オプション

名前

特徴定義の一意の識別子を入力します。 各ファイル内で2つの特徴定義に同じ名前を付けることはできません。

コード

特徴定義の名前の一意の略記を入力します。

カテゴリ

特徴定義を格納するカテゴリを選択します。

タイプ

ポイントの特徴 - ポイントの特徴定義を作成する場合は、このオプションを選択します。 ポイントの特徴は、樹木や電柱など、1つの特徴を識別するために使用します。

ライン特徴 -ラインの特徴定義を作成する場合は、このオプションを選択します。 ライン特徴は、フェンスや道などのラインを定義する2つ以上のポイントで構成されます。

レイヤー

ファイルに対してレイヤーが定義されている場合は、特徴定義に適切なレイヤーを選択します。 または、次のオプションを1つ選択します。

0 - 新しい特徴をデフォルトのレイヤに配置する場合に選択します。

ポイント - ポイントの特徴をその他のポイント特徴と同じレイヤーに配置する場合に選択します。

<<新しいレイヤー>> - 新しいレイヤーダイアログを表示して、新しいレイヤーの以下のプロパティを定義する場合に選択します。

  • レイヤー名
  • 色
  • ラインスタイル

    ラインスタイルをインポートする必要がある場合は、<<ラインスタイルをインポート>>オプションを選択します。 ラインスタイルマネージャダイアログが表示されます。 このダイアログでは、ラインスタイルのインポートおよび削除を行うことができます。 手順については、「ラインスタイルの操作」を参照してください。

色

レイヤーを基準に - 特徴の表示色を特徴のレイヤーから継承する場合に選択します。

(色) - 画像表示で特徴定義を表示する際の特定の色を選択します。

ラインスタイル

適切なラインスタイルを選択します。

ラインスタイルをインポートする必要がある場合は、<<ラインスタイルをインポート>>オプションを選択します。 ラインスタイルマネージャダイアログが表示されます。 このダイアログでは、ラインスタイルの削除を行うことができます。 手順については、「ラインスタイルの操作」を参照してください。

このオプションは、ライン特徴定義を作成または編集する場合にのみ使用可能です。

ラインスタイルスケール

ラインを表すために使用するシンボルのスケールファクターを入力します。

このオプションは、ライン特徴定義を作成または編集する場合にのみ使用可能です。

面に含める

特徴コードが別のアプリケーションで処理された後に、面作成操作で特徴を使用する場合にオンにします。

関連項目

特徴定義の操作

特徴定義の作成および編集

ラインスタイルの操作


ラインスタイルの操作

ラインを作成または編集するときに<<ラインスタイルをインポート>>オプションを選択すると、ラインスタイルマネージャダイアログが表示されます。

ラインスタイルをインポートするには

  1. 適切な長さの単位および単位参照を選択します。
  2. 参照ボタンをクリックして、ラインスタイルのインポート元となるラインスタイルファイルを選択します。
  3. インポートするラインスタイルを右側のリストで1つまたは複数選択し、< (移動)ボタンをクリックして、選択したラインスタイルを左側のリストに移動します。または、<< (移動)ボタンをクリックして、右側のリスト内のすべての項目を左側のリストに移動します。 左側のリストには、プロジェクトで使用可能なすべてのラインスタイルが表示されます。
  4. 作業が終了したら、OKをクリックします。 インポートされたラインスタイルがラインスタイルリストに表示され、選択できるようになります。

ラインスタイルを削除するには

  1. 左側のリストで、削除するラインスタイルを選択します。
  2. 削除(X)ボタンをクリックします。
  3. 作業が終了したら、OKをクリックします。

関連項目

特徴定義オプション

オフセット特徴ラインのオプション


特徴シンボルの操作

特徴は、オフィス測量処理ソフトウェアの画像表示でシンボルとして表示できます。 それぞれの特徴定義で使用するシンボルを指定できます。

関連項目

特徴シンボルの割り当て、編集、および削除

特徴シンボルオプション


特徴シンボルの割り当て、編集、および削除

シンボルを特徴定義に割り当てるには:

  1. エクスプローラペインで、シンボルを割り当てる特徴定義を右クリックして、新規作成 > 新しいシンボルを選択します。 シンボルダイアログが表示されます。
  2. 「特徴シンボルオプション」の説明に従って、フィールドに値を入力します。
  3. 作業が終了したら、OKをクリックします。 新しく割り当てられたシンボルがラインとシンボルリストに表示されます。

シンボルを編集するには:

  1. エクスプローラペインで、シンボルを編集する特徴定義をクリックします。
  2. ラインとシンボルリストで、編集するシンボルをダブルクリックします。 シンボルダイアログが表示されます。
  3. 「特徴シンボルオプション」の説明に従って、フィールドに値を入力します。
  4. 作業が終了したら、OKをクリックします。

シンボルを削除するには:

  1. エクスプローラペインで、シンボルを削除する特徴定義をクリックします。
  2. ラインとシンボルリストで、削除するシンボルをダブルクリックします。
  3. コンテキストメニューの削除をクリックします。

関連項目

特徴シンボルの操作

特徴シンボルオプション


特徴シンボルオプション

シンボルダイアログに表示されるこれらのオプションを使用して、シンボルのプロパティを定義します。

オプション

名前

シンボルの識別子を入力します。

説明

シンボルに関する全般的なコメントを入力します。

シンボル

特徴を表現するシンボルを選択します。

シンボルをインポートする必要がある場合は、<<シンボルのインポート>>オプションを選択します。 シンボルマネージャダイアログが表示されます。 このダイアログでは、シンボルのインポートおよび削除を行うことができます。 手順については、「シンボルの操作」を参照してください。

色

レイヤー準拠 - 測量後処理ソフトウェアで特徴コードが配置されているレイヤーの色を使用する場合に選択します。

ブロック / 特徴を基準に - 特徴が配置されているレイヤーの色を使用する場合に選択します。

(色) - 適切な色を選択します。

配置

回転

固定値 - 値ボックスを開いて、シンボルの回転角度を入力する場合に選択します。 回転の向きは左回りです。

属性 - 属性名リストを開いて、適切な属性名を選択する場合に選択します。 シンボルは、属性で定義されている値(角度)で回転します。

シンボルサイズとスケール

Dimensioning

地上 - 固定値または属性に基づいて特定の地上サイズにシンボルをスケールする場合は、このオプションを選択します。

紙面 - 固定値または属性に基づいて、プロジェクトに対して定義されたプロットスケールにシンボルをスケールする場合は、このオプションを選択します。

入力方法

固定値 - 値ボックスを開いてシンボルのサイズを入力する場合は、このオプションを選択します。

Dimensioningグループボックスで地上を選択した場合、シンボルは入力した値に基づいて地上サイズにスケールされます。 たとえば、1メートルと入力すると、シンボルの地上サイズは1メートルになります。

Dimensioningグループで紙面を選択した場合、シンボルは入力した値に基づいて、プロジェクトに対して定義されたプロットスケールにスケールされます。 たとえば、1ミリメートルと入力して、プロジェクトのプロットスケールが100の場合、シンボルの地上サイズは0.1メートル(1 mm x 100) になります。 Feature Definition Managerでシンボルを表示するために使用される既定のプロットスケールは100です。しかし、実際のプロジェクトのプロットスケールは異なる場合があります。

属性 - 属性名リストを開いて、適切な属性名を選択する場合に選択します。 シンボルのサイズは、属性に対して指定された値に基づいて設定されます。

Dimensioningグループボックスで地上を選択した場合、シンボルは、選択した属性に対して指定された値に基づいて地上サイズにスケールされます。たとえば、値が1の属性を選択し、表示単位がメートルの場合、シンボルの地上サイズは1メートルになります。

Dimensioningグループで紙面を選択した場合、シンボルは、選択した属性に対して指定された値に基づいて、プロジェクトに対して定義されたプロットスケールにスケールされます。 たとえば、値が1の属性を選択して、プロジェクトのプロットスケールが100の場合、シンボルの地上サイズは0.1メートル(1 mm x 100) になります。 Feature Definition Managerでシンボルを表示するために使用される既定のプロットスケールは100です。しかし、実際のプロジェクトのプロットスケールは異なる場合があります。

注記: 表示単位を変更するには、プリファレンスの編集ボタンをクリックします。 ここで選択した表示単位は、プロジェクトで使用する表示単位に一致する必要があります。

関連項目

特徴シンボルの操作

特徴シンボルの割り当て、編集、および削除

シンボルの操作


シンボルの操作

シンボルを操作するときに<<シンボルのインポート>>オプションを選択すると、シンボルマネージャダイアログが表示されます。

シンボルをインポートまたは削除するには

  1. シンボルマネージャダイアログで、 [image] ボタンをクリックして、インポートするシンボルを含むファイルを指定します。

    既定のシンボルファイルは、次の場所にあります。
    C:\Program Files\Trimble\Feature Definition Manager\PEditor\Symbols.sym
  1. 以下のいずれかの操作を行います。
    • 選択したファイルに含まれるすべてのシンボルをインポートするには、<<ボタンをクリックします。
    • 選択したファイルから1つのシンボルをインポートするには、インポートするシンボルを右側のリストで選択して、<ボタンをクリックします。
    • シンボルを削除するには、削除するシンボルを左側のリストで選択してXボタンをクリックします。
  2. 作業が終了したら、OKをクリックします。

関連項目

特徴シンボルオプション


オフセット特徴ラインの操作

1つの中央線とは対照的に、ライン特徴にオフセットラインを作成する場合は、ラインを定義する特徴定義にオフセットラインを割り当てることができます。 たとえば、歩道のライン特徴に2つのオフセットラインを追加することが考えられます。1つのオフセットラインは、歩道の中央線から左に2単位の位置にある左側の縁を定義し、もう1つのオフセットラインは、右に2単位の位置にある右側の縁を定義します。 この場合、特徴定義に2つのオフセットラインを追加できます。1つのオフセットラインには2の水平オフセット値を使用し、もう1つのオフセットラインには-2の水平オフセットラインを使用します。 必要に応じてオフセットラインごとに異なる色とスタイルを使用することもできます。

注記: オフセットラインをライン特徴定義に追加すると、中央線は表示されなくなります。

関連項目

オフセット特徴ラインの割り当て、編集、および削除

オフセット特徴ラインのオプション


オフセット特徴ラインの割り当て、編集、および削除

オフセットラインをライン特徴定義に割り当てるには:

  1. エクスプローラペインで、オフセットラインを割り当てるライン特徴定義を右クリックして、新規作成 > 新しいラインを選択します。 ラインダイアログが表示されます。
  2. 「オフセット特徴ラインのオプション」の説明に従って、フィールドに値を入力します。
  3. 作業が終了したら、OKをクリックします。 新しく割り当てられたオフセットラインがラインとシンボルリストに表示されます。

オフセットラインを編集するには:

  1. エクスプローラペインで、オフセットラインを編集する特徴定義をクリックします。
  2. ラインとシンボルリストで、編集するオフセットラインをダブルクリックします。 ラインダイアログが表示されます。
  3. 「オフセット特徴ラインのオプション」の説明に従って、フィールドに値を入力します。
  4. 作業が終了したら、OKをクリックします。

オフセットラインを削除するには:

  1. エクスプローラペインで、オフセットラインを削除する特徴定義をクリックします。
  2. ラインとシンボルリストで、削除するオフセットラインをダブルクリックします。
  3. コンテキストメニューの削除をクリックします。

関連項目

オフセット特徴ラインの操作

オフセット特徴ラインのオプション


オフセット特徴ラインのオプション

ラインダイアログに表示されるこれらのオプションを使用して、オフセット特徴ラインのプロパティを定義します。

オプション
名前 | オフセットラインの識別子を入力します。
説明 | オフセットラインに関する全般的なコメントを入力します。
スタイル | 適切なラインスタイルを選択します。 ラインスタイルをインポートする必要がある場合は、<<ラインスタイルをインポート>>オプションを選択します。 ラインスタイルマネージャダイアログが表示されます。 このダイアログでは、ラインスタイルのインポートおよび削除を行うことができます。 手順については、「ラインスタイルの操作」を参照してください。
スケール | ラインを表すために使用するシンボルのスケールファクターを入力します。
色 | レイヤー準拠 - 測量後処理ソフトウェアで特徴コードが配置されているレイヤーの色を使用する場合に選択します。 ブロック / 特徴を基準に - 特徴が配置されているレイヤーの色を使用する場合に選択します。 (色) - 適切な色を選択します。
水平オフセット | 特徴の中央線からオフセットラインまでの水平距離を入力します。 追加のラインが作成されます。
垂直オフセット | 特徴の中央線からオフセットラインまでの垂直距離を入力します。 追加のラインが作成されます。
オフセットタイプ | 地上 - 水平および垂直オフセット距離に実際のプロジェクト単位を使用する場合に選択します。 シート - 水平および垂直オフセット距離に紙面単位を使用する場合に選択します。

関連項目

オフセット特徴ラインの操作

オフセット特徴ラインの割り当て、編集、および削除

ラインスタイルの操作


特徴属性の操作

特徴属性は、特徴定義に割り当てられた特性で、特徴を詳細に説明するために使用されます。 特徴属性は、以下の目的で使用できます。

  • 現場作業員が特徴にすばやく適用できるように一般的な特性を事前に定義する。 たとえば、「樹木」という特徴には、種、高さ、周囲、および状態という属性を追加できます。 現場で記録された個々の特徴には、これらの属性の独自の値を設定できます。
  • 現場の特徴に関して収集できる情報のタイプおよび収集する必要のある情報のタイプを制御します。 たとえば、記録する個々の樹木にシンボルが必要となるようにする場合、樹木特徴にシンボル属性を追加して、その属性を必須に指定できます。 この場合、現場作業員が現場の収集装置で、記録する個々の特徴にシンボルを指定する必要があります。

関連項目

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性の割り当ておよび編集

特徴定義に属性を割り当てるには:

  1. エクスプローラペインで、属性を割り当てる特徴定義を右クリックして、新規作成 > 新しい属性 > (属性タイプ)を選択します。 選択した属性タイプのダイアログが表示されます。

    使用可能な各属性のタイプの詳細、およびそれぞれの(属性タイプ)ダイアログでプロパティを入力する方法に関するトピックへのリンクについては、「特徴属性のオプション」を参照してください。

  2. (属性タイプ)ダイアログでプロパティを指定したら、OKをクリックします。 新しく追加された属性が、メインウィンドウ内の特徴定義の属性リストに表示されます。

既存の属性を編集するには:

  1. エクスプローラペインで、属性を編集する特徴定義をクリックします。
  2. 属性リストで、編集する属性をダブルクリックします。 (属性タイプ)ダイアログが表示されます。
  3. 「特徴属性のオプション」の説明に従って、フィールドに値を入力します。
  4. 作業が終了したら、OKをクリックします。

関連項目

特徴属性の操作

特徴属性のオプション


特徴属性のオプション

以下のオプションを使用して、現場で特徴を記録する際に現場作業員が選択できる属性を追加できます。 これらのオプションは、特徴を右クリックして、コンテキストメニューから新規作成 > 新しい属性を選択します。

オプション
数値 | 樹木の周囲や高さ、特定の場所の汚染物質の濃度などの数値属性をキャプチャする必要がある場合に選択します。 数値属性ボックスに入力できるのは整数または小数だけです。
テキスト | 通りの名前や公共施設の所有者名など、英数文字を使用して属性をキャプチャする必要がある場合に選択します。 テキスト属性には数値を追加できますが、属性が常に数値の場合は数値属性を使用します。
日付 | 電柱の設置日などのように、標準の日付フォーマットで属性をキャプチャする必要がある場合に選択します。
時間 | 特徴を記録した時刻など、時間フォーマットで属性をキャプチャする必要がある場合に選択します。
リスト | プロジェクト内で考えられる5つのモニュメントタイプなど、リスト内の複数のオプションから選択して属性をキャプチャする必要がある場合に選択します。
ファイル | ファイル属性をキャプチャする必要がある場合に選択します。
写真 | 写真属性をキャプチャする必要がある場合に選択します。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集


特徴属性: 数値オプション

これらのオプションを使用して、数値で構成される属性を定義します。 これらのオプションは、数値ダイアログで使用可能です。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性はコンピュータで入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。
既定値 | 最も一般的に入力される値を入力します。この値は、属性ボックスに自動的に表示されます。
現場装置固有 |
最小値 | 属性に設定できる最小値を入力します。
最大値 | 属性に設定できる最大値を入力します。
小数点以下の桁数 | 小数点以下の桁数を入力します。 0の値を入力した場合、入力できるのは整数だけになります。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: 整数オプション

これらのオプションを使用して、整数値で構成される属性を定義します。 これらのオプションは、整数ダイアログで使用可能です。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性はコンピュータで入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。
既定値 | 最も一般的に入力される値を入力します。この値は、属性ボックスに自動的に表示されます。
現場装置固有 |
最小値 | 属性に設定できる最小の整数値を入力します。
最大値 | 属性に設定できる最大の整数値を入力します。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: テキストオプション

これらのオプションを使用して、入力するテキスト属性を定義します(テキスト属性は文字、数値、およびその他の文字の文字列で構成されます)。 これらのオプションはテキストダイアログで使用できます。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性は特徴ファイル定義に入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。
既定値 | 最も一般的に入力される値を入力します。この値は、属性ボックスに自動的に表示されます。 既定値を入力しない場合、この属性の初期値はNull (値なし)に設定されます。
最大長 | 入力できる最大文字数を指定します(最大100文字)。 このフィールドには値を設定する必要があります既定値は30です。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: 日付オプション

これらのオプションを使用して、日付属性のフォーマットを定義します。 これらのオプションは、日付ダイアログで使用可能です。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を設定しない場合に選択します。属性はコンピュータから入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 現場で属性を入力する必要がある場合に選択します。
フォーマット | リストから日付フォーマットを選択します。 注記: 使用可能なGISエクスポートフォーマットの1つにデータをエクスポートするには、日付属性に指定した日付フォーマットとGISソフトウェアがインストールされているコンピュータの日付フォーマットが同じであることを確認してください。 多くのGISシステムでは、ファイルをインポートする際にコンピュータの日付設定がチェックされ、ファイルの日付がコンピュータで設定されているフォーマットと同じであることが前提とされます。 設定が異なる場合は、GISソフトウェアの値がNull値になります。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: 時間オプション

これらのオプションを使用して、時間属性のフォーマットを定義します。 これらのオプションは、時間ダイアログで使用可能です。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性はコンピュータで入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。
フォーマット | リストから時間フォーマットを選択します。 注記: 使用可能なGISエクスポートフォーマットの1つにデータをエクスポートするには、日付属性に指定した日付フォーマットとGISソフトウェアがインストールされているコンピュータの日付フォーマットが同じであることを確認してください。 多くのGISシステムでは、ファイルをインポートする際にコンピュータの日付設定がチェックされ、ファイルの日付がコンピュータで設定されているフォーマットと同じであることが前提とされます。 設定が異なる場合は、GISソフトウェアの値がNull値になります。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: リストオプション

これらのオプションを使用して、定義済みの選択可能な値を必要とする属性を定義します。 これらのオプションは、リストダイアログで使用可能です。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性はコンピュータで入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。
値のリスト | ボタンを使用してリストを構築します。このリストから、オプションを選択できます。 上へ - クリックすると、選択したリスト項目がリスト内で上に移動します。 下へ - クリックすると、選択したリスト項目がリスト内で下に移動します。 既定値 - クリックすると、ここで選択した項目が、ユーザが選択を行わなかった場合にリストに表示される値になります。 追加 - クリックすると、新しいエントリがリストに挿入されます。 次に、エントリを入力します。 削除 - クリックすると、リストから項目が削除されます。 注記: リストのエントリを編集するには、目的のエントリを値のリストで選択して、新しい名前を入力します。
既定値 | 最も一般的に入力される値を入力します。この値は、属性ボックスに自動的に表示されます。 既定値を入力しない場合、この属性の初期値はNull (値なし)に設定されます。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: ファイルオプション

これらのオプションを使用して、ファイル属性を定義します。 これらのオプションは、ファイルダイアログで使用できます。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性はコンピュータで入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


特徴属性: 写真オプション

これらのオプションを使用して、写真属性を定義します。 これらのオプションは、写真ダイアログで使用可能です。

オプション
名前 | 属性の識別子を入力します。
説明 | 属性に関する一般的なコメントを入力します。 このボックスはオプションで、現場での作業では使用されません。
入力モード | オフィス使用のみ - 現場で属性を指定できない場合に選択します。属性はコンピュータで入力する必要があります。 オプション - 属性を指定するかどうかをユーザが選択できる場合に選択します。 必須 - 有効な値で属性を指定する必要がある場合に選択します。 自動生成 - 属性が装置でキャプチャされた写真である必要がある場合に選択します。 自動生成-読み取り専用 - 属性が装置でキャプチャされた写真である必要があり、装置で写真を編集できない場合に選択します。

関連項目

特徴属性の操作

特徴属性の割り当ておよび編集

特徴属性のオプション


ライン制御コードの操作

測量技師は、現場データを収集する際にライン制御コードをポイントに割り当てて、関連するライン特徴のプロパティを指定できます。 たとえば、ライン制御コードをポイントに割り当てて、特徴ラインが開始または終了する場所を指定できます。 オフィス測量処理ソフトウェアで特徴コードを処理すると、オブジェクトは、コードの指示に従ってライン制御コードによって変更されます。

注記: 使用可能な制御コードの定義済みリストを編集できますが、個々のコードによって実行されるアクションを変更することはできません。

関連項目

ライン制御コードの作成および編集

ライン制御コードオプション


ライン制御コードの作成および編集

新しいライン制御コードを作成するには

  1. 以下のいずれかの操作を行います。
    • 編集 > 新規作成 > 新しいライン制御コードを選択します。
    • エクスプローラペインを右クリックして、新規作成> 新しいライン制御コードを選択します。
    • ツールバーの i_new control code アイコンをクリックします。

    ライン制御コードダイアログが表示されます。

    注記: ライン制御コードダイアログで使用可能なすべてのオプションの詳細については、「ライン制御コードオプション」を参照してください。

  2. 名前ボックスにコードの識別子を入力します。
  3. コードボックスにコードの略記を入力します。
  4. コードが実行するアクションをすべてのアクションリストで選択します。 リストの上にある選択されたアクションボックスに、コードによって特徴がどのように変更されるかに関する情報が表示されます。
  5. OKをクリックします。

既存のライン制御コードを編集するには:

  1. 編集するコードをエクスプローラペインで編集します。 メインウィンドウにライン制御コードのプロパティが表示されます。
  2. 名前またはコードボックスをクリックして、必要な編集を行います。

    注記: 既存のライン制御のアクションは変更できません。

  3. [TAB]キーを押すか、エクスプローラペインで別の項目を選択して、変更を適用します。

関連項目

ライン制御コードの操作

ライン制御コードオプション


ライン制御コードオプション

これらのオプションを使用して、制御コードの変更および新規作成を行います。 これらのオプションは、新しいライン制御コードダイアログで使用できます。

オプション

名前

制御コードの識別子を入力します。

コード

現場で使用するライン制御コードの略記を入力します。

選択されたアクション

選択した制御コードによって特徴がどのように変更されるかに関する情報が表示されます。

すべてのアクション

ラインを開始

新しいライン結合シーケンスを開始する場合に選択します。 同じコードでの以前の結合シーケンスは終了します。

このオプションは、ポイントが同じコードで以前のポイントに結合されることを防止し、新しい結合シーケンスを開始するために使用します。

一部のアプリケーションでは、同じ名前のライン特徴が自動的に結合する場合、この制御コードは新しいラインを開始するために必要ありません。

注記: ラインを開始を使用して、ラインを終了と同じような結果を得ることができます。

ラインを終了

新しいライン結合シーケンスを開始する場合に選択します。

このオプションは、ラインを終了コードのポイントと同じ特徴コードの次のポイントの間でラインが描画されることを防止する場合に使用します。

ポイントに結合

指定したポイントIDにラインシーケンスを結合させる場合に選択します。

結合を無視

結合操作を無視する場合に選択します。

ポイントに閉合

同じ特徴コードのシーケンスの最初のポイントに閉合する場合に選択します。 少なくとも3つのポイントが必要です。 ポイントには同じ特徴コードが必要で、最終ポイントの特徴コードの後には閉合制御コードが必要です。

このオプションは、新しい特徴が開始した場合または特徴が終了した場合に特徴を閉合するために使用します。

使用された共通の特徴コードに対してラインスタイルが定義されている場合、定義されているラインスタイルを使用して閉合が描画されます。 スタイルが定義されていない場合、ラインは現在のレイヤーの既定のラインスタイルで描画されます。

ヒント: 最初にレイヤーの既定のラインスタイルを設定します。

正接円曲線開始

正接円曲線を開始する場合に選択します。 開始接線を定義するポイントが必要です。 開始接線の方向は、開始曲線制御コードを持つポイントおよび同じ特徴コードを持つ以前のポイントの間の方位角によって定義されます。

円曲線は、以下の状況で作成できます。

  • 開始接線および終了接線の方向を定義するために使用可能なポイントが存在する場所で接線方向に開始および終了する円曲線。 このことは、完全な正接円曲線には4つのポイントが必要なことを意味します。 2つの接線ポイントから計算された半径が完全に同じではない場合、2つの真の接線ポイントを得るために、新しいポイントおよび短接線ラインセグメントが追加されます。
  • 開始接線の方向を定義するために使用可能なポイントがあり、接線方向に開始し非接線方向に終了する円曲線。 システムでは、円曲線の終了ポイントと共に既知の接線ポイントおよび接線方向を使用して、円曲線の中心ポイントが計算されて円曲線が追加されます。
  • 1つ以上のポイントが円曲線上に固定されていて、非接線方向に開始し、非接線方向に終了する円曲線。 システムでは、円曲線に沿って固定されたポイントを使用して、ポイント全体で最適な中心ポイントが計算されて円曲線が追加されます。 3つのポイントが使用されている場合、円曲線は中央のポイントを通過します。

正接円曲線終了

正接円曲線を終了する場合に選択します。 終了接線を定義するポイントが必要です。 終了接線の方向は、終了曲線制御コードを持つポイントおよび同じ特徴コードを持つ次のポイントの間の方位角によって定義されます。

これらの制御コードが使用される場合、円曲線の中心ポイントは、使用可能なデータによる計算によって定義されます。

非正接円曲線開始

非正接円曲線を開始する場合に選択します。 同じ特徴コードを持つ前のポイントは必要ありません。

非正接円曲線には、3つ以上のポイントが必要です(新しい円曲線の開始ポイント、終了ポイント、およびこれらのポイントの間にあり円曲線を定義する1つ以上のポイント)。 使用するポイントは同じ特徴コードを持つ必要があります。

注記: 新しい円曲線の開始ポイントと終了ポイントの間に同じ特徴コードのポイントがない場合、円曲線は正接円曲線として描画され、2つのポイントの間にある中間ポイントが中心ポイントになります。

非正接円曲線終了

非正接円曲線を終了する場合に選択します。 この方法で円曲線を終了する場合は、同じ特徴コードを持つ次のポイントは必要ありません。

前の新しい円曲線制御コードによって開始された非正接円曲線が終了されます。 円曲線は3つのポイントによって定義されます。 これらの制御コードを使用すると、ポイント間に最適な曲線が描画されます。 曲線から中心ポイントが決定されます。

関連項目

ライン制御コードの操作

ライン制御コードの作成および編集


特徴定義/ライン制御グループの操作

現場装置によっては、装置のボタンに対応するように、特徴定義コードおよびライン制御コードのセットをグループ化できる場合があります。 複数のグループを作成することにより、現場の作業者が特定の作業で必要なグループを選択できるようにすることができます。

関連項目

特徴定義/ライン制御グループの作成および編集

グループオプション


特徴定義/ライン制御グループの作成および編集

特徴定義およびライン制御コードのグループを作成するには:

  1. エクスプローラペインで新しいグループを追加するファイルをクリックします。
  2. 以下のいずれかの操作を行います。
    • 編集 > 新規作成 > 新しいグループを選択します。
    • ツールバーの [image] アイコンをクリックします。

    グループのプロパティペインが表示され、エクスプローラペインに新しいグループアイコンが表示されます。

    注記: グループのプロパティペインで使用可能なすべてのオプションの詳細については、「グループオプション」を参照してください。

  3. 名前および説明ボックスに値を入力します。
  4. すべてのコードリストで特徴定義またはライン制御コードを選択します。
  5. 左向きの矢印をクリックして、コードを左側のグループ内のコードリストに移動します。

    注記: すべてのコードリスト内のコードをダブルクリックして、すべてのコードをグループに移動することもできます。

    次の手順で説明するように、2つ以上の特徴定義またはライン制御コードをマージすると、現場の特徴に簡単に割り当てることができます。

  6. 特徴定義コードおよびライン制御コードをマージするには:
    1. マージするコードをグループ内のコードリストで選択します。
    2. グループ内のコードリストで選択したコードにマージするコードをすべてのコードリストで選択します。
    3. アイコンをクリックします。 2番目に選択したコードがグループ内のコードリストのコードと結合されます。
    4. 必要に応じて、この手順を繰り返して、その他のコードをマージします。
  7. この手順を繰り返して、追加のコードをグループに追加します。 グループに含めることのできるコードの総数が、グループ内のコードリストの上に表示されます。

    注記: 特徴コードは、複数のグループに配置できます。 コードが別の制御コードにマージされている場合、1つのグループ内で1つの特徴コードを複数回使用することもできます。

  8. 必要な場合は、上向きまたは下向きの矢印アイコンをクリックして、グループ内でコードを再配置します。
  9. 作業が終了したら、エクスプローラペイン内の別のオブジェクトをクリックして変更内容を保存します。

既存のグループを編集するには:

  1. エクスプローラペインで、編集するグループの名前をクリックします。 グループのプロパティペインが表示されます。
  2. 必要に応じて名前および説明を変更します。
  3. 必要に応じて、上記の説明に従ってグループ内のコードリストを変更します。
  4. 作業が終了したら、エクスプローラペイン内の別のオブジェクトをクリックして変更内容を保存します。

関連項目

特徴定義/ライン制御グループの操作

グループオプション


グループオプション

これらのオプションを使用して、現場装置で使用する特徴定義およびライン制御コードの新しいグループを作成します。 これらのオプションは、グループのプロパティペインで使用できます。

オプション
名前 | グループの識別子を入力します。
説明 | グループに関する追加説明を入力します。
コード | グループ内のコード - グループに追加されている特徴定義およびライン制御コードが表示され、これらの特徴およびライン制御コードを選択、削除、または再配置できます。 すべてのコード - 現在のファイルに含まれているすべての特徴定義およびライン制御コードが表示され、これらの特徴およびライン制御コードを選択してグループに追加できます。 アルファベット順に並べ替える - このボックスをオンにすると、現場装置でグループ内のコードリストがアルファベット順に表示されます。

関連項目

特徴定義/ライン制御グループの操作

特徴定義/ライン制御グループの作成および編集


特徴定義データのエクスポートおよびアップロード

特徴定義データを現場装置に直接"アップロード"することや、特徴定義データをファイルに"エクスポート"することができます。 属性を含むかどうかに関係なく、すべての特徴定義がエクスポートされますが、ライン制御コードはエクスポートされません。 特徴定義は、ポイント特徴としてエクスポートされます。

特徴定義データを現場装置にアップロードするには:

  1. データのエクスポート元のファイル、またはそのファイルのネストノードの1つがエクスプローラペインで選択されていることを確認します。
  2. 現場装置をコンピュータに接続します。
  3. ファイル > エクスポートをクリックします。 ファイルのエクスポートダイアログボックスが表示されます。
  4. 装置にアップロードをクリックします。
  5. 装置名のリストで現場装置を選択します。
  6. アプリケーションのリストでプログラムを選択します。
  7. OKをクリックします。

特徴定義データをファイルにエクスポートするには:

  1. データのエクスポート元のファイル、またはそのファイルのネストノードの1つがエクスプローラペインで選択されていることを確認します。
  2. ファイル > エクスポートをクリックします。 ファイルのエクスポートダイアログボックスが表示されます。
  3. ファイルにエクスポートをクリックします。
  4. ファイルタイプリストでエクスポートファイルのフォーマットを選択します。
  5. 以下のいずれかの操作を行います。
    • ターゲットファイルボックスにファイルのパスと名前を入力します。
    • ボタンをクリックして、名前を付けて保存ダイアログを表示します。 名前を付けて保存ダイアログで、ファイルの名前を入力し、ファイルタイプを選択して、ファイルを保存する場所を選択します。 OKをクリックします。 ターゲットファイルボックスにパスおよびファイル名が表示されます。
  6. ファイルのエクスポートダイアログでOKをクリックします。

関連項目

エクスポートおよびアップロードオプション

インポートおよびエクスポートフォーマット

データディクショナリファイル(.ddf)のエクスポート


エクスポートおよびアップロードオプション

これらのオプションを使用して、別のアプリケーションまたは現場装置にデータを送信します。 これらのオプションは、ファイルのエクスポートダイアログで使用できます。

オプション
ソースファイル | エクスポートするファイルのパスを選択または入力します。または、 [image] アイコンをクリックして、別のディレクトリにナビゲートします。
ファイルにエクスポート | ソースファイルをコンピュータまたはネットワーク上の別のファイルの場所にエクスポートする場合に選択します。
装置にアップロード | 現場装置にファイルをアップロードする場合に選択します。
ファイルタイプ | エクスポートするファイルフォーマットを選択します。
ターゲットファイル | ファイルのエクスポート先のパスを選択または入力します。または、 [image] アイコンをクリックして、別のディレクトリにナビゲートします。
装置名 | 接続している現場装置の名前が表示されます。
アプリケーション | ファイルを使用するソフトウェアを選択します。

関連項目

特徴定義データのエクスポートおよびアップロード

インポートおよびエクスポートフォーマット

データディクショナリファイル(.ddf)のエクスポート


データディクショナリファイル(.ddf)のエクスポート

Trimble GPS Pathfinderソフトウェアを使用している場合、データディクショナリファイル(.ddf)をデータディクショナリエディタにエクスポートできます。 このフォーマットで特徴データをエクスポートすると、データディクショナリエディタで属性を再作成する必要がなくなります。

  • 選択されている内容に関係なく、ファイルに含まれるすべての特徴定義がデータディクショナリファイルにエクスポートされます。 属性が含まれているかどうかに関係なく、特徴定義がエクスポートされます。
  • 特徴定義は、ポイント特徴としてエクスポートされます。 特徴タイプは、データディクショナリエディタでラインに変更できます。
  • データディクショナリファイルに含まれるのは、特徴の名前、コード、および属性だけです。 レイヤー、ラインスタイル、グループ、制御コードなど、その他の特徴情報はエクスポートされません。

関連項目

特徴定義データのエクスポートおよびアップロード

エクスポートおよびアップロードオプション

インポートおよびエクスポートフォーマット


レポートの表示

さまざまなレポートを表示できます。 レポートを表示するには、ファイル > レポートを選択して、表示するレポートを選択します。 選択したレポートが新しいブラウザウィンドウに表示されます。


Previous Topic

Next Topic

法的通知


企業オフィス

Trimble Navigation Limited
Engineering and Construction Division
5475 Kellenburger Road
Dayton, Ohio 45424-1099
U.S.A.

電話: +1-937-233-8921
フリーダイヤル(米国内のみ): +1-800-538-7800
Fax: +1-937-233-9441

www.trimble.com

著作権および商標

© 2006-2011, Trimble Navigation Limited. All rights reserved.

地球儀と三角形のロゴおよびTrimbleは、米国特許商標局およびその他の国に登録されているTrimble Navigation Limitedの商標です。 Digital FieldbookおよびTrimble Geomatics Officeは、Trimble Navigation Limitedの商標です。 InterlockおよびReconは、Trimble Navigation Limitedの完全子会社であるTripod Data Systems, Inc.の商標です。 MicrosoftおよびWindowsは、米国およびその他の国におけるMicrosoft Corporationの登録商標または商標です。 その他のすべての商標は、それぞれの所有者に帰属します。

リリースに関する通知

これは、Trimble®特徴定義マネージャソフトウェアのバージョン2.08のヘルプです。