Общие сведения о Диспетчере определений объектов

Вы читаете встроенную справку Диспетчера определений объектов. Этот программный инструмент позволяет создавать определения (свойства) объектов, которые можно легко загрузить на полевые устройства, чтобы полевые партии назначали их объектам, обнаруженных в поле, а также управлять ими. Затем можно использовать офисную программу обработки геодезических данных для обработки объектов в сочетании с другими зарегистрированными геодезическими данными и экспорта их в другие системы (например пакеты программ CAD)

Описание Диспетчера определений объектов

«Объекты» представляют природные и антропогенные предметы, которые геодезисты могут измерить и зарегистрировать при сборе полевых данных. Это могут быть, например, деревья, заборы, ворота, знаки, столбы и здания. Чтобы легко и эффективно регистрировать информацию об измеряемых объектах, геодезист может использовать полевое устройство для выбора объектов из предварительно назначенной библиотеки, называемой «определения объектов», и назначения объекту соответствующего определению уникального кода объекта. Это позволяет назначить для объекта все свойства, связанные с определением объекта (например имя и код объекта, символ, используемый для представления его в графических видах программы, а также любые другие настроенные атрибуты).

Существует два основных типа объектов, каждый из которых представлен различным типом определения объекта.

  • Объект-точка используется для определения одного объекта, такого как дерево или столб. Определение объекта-точки представляется значком [image] в панели «Проводник».
  • Объект-линия состоит из двух или нескольких точек, определяющих линию, например забор или дорожку. Определение объекта-линии представляется значком [image] в панели «Проводник». К объектам-линиям также могут относиться коды управления линиями, использующиеся для дополнительного определения линейных объектов (например добавления линий, кривых и дуг между точками).

См. также:

Последовательность операций для Диспетчера определений объектов

Описание интерфейса


Последовательность операций для Диспетчера определений объектов

Следующие шаги представляют собой общую последовательность операций для работы с Диспетчером определений объектов. Для получения дополнительной информации нажимайте соответствующие ссылки.

  1. Откройте или создайте файл определений объектов (.fxl) или загрузите или импортируйте данные определений объектов.
  2. Введите и отредактируйте свойства файла определений объектов (.fxl).
  3. Создайте и отредактируйте категории определений объектов.
  4. Создайте и отредактируйте определения объектов.
  5. Создайте и отредактируйте символы, используемые для определений объектов.
  6. Создайте и отредактируйте смещенные линии, используемые с определениями объектов-линий.
  7. Добавьте и отредактируйте атрибуты определений объектов.
  8. Создайте и отредактируйте коды управления линиями.
  9. Создайте группы кодов определений объектов и кодов управления линиями.
  10. Сохраните файл определений объектов (.fxl).
  11. Экспортируйте файл или загрузите его в полевое устройство.

См. также:

Общие сведения о Диспетчере определений объектов

Описание интерфейса


Описание интерфейса

В интерфейсе пользователя Диспетчера определений объектов используются обычные элементы.

Интерфейс пользователя

Строка меню

Предоставляет доступ ко всем командам. Возможные действия перечислены ниже.

  • Щелчок пункта меню
  • Нажатие клавиши [Alt] и подчеркнутой буквы пункта меню (мнемонический символ). Затем можно нажать другую мнемоническую клавишу или выбрать пункт меню с помощью кнопок со стрелками «вверх» и «вниз», после чего нажать клавишу [Enter].

Панели инструментов

Обеспечивают быстрый доступ к наиболее часто используемым командам посредством значков.

В панели инструментов также имеется поле поиска, в которое можно ввести код объекта. Нажатием клавиши [Enter] производится поиск и выбор объекта в панели «Проводник».

Панель «Проводник»

Отображает представление в виде дерева категорий, объектов, кодов управления линиями и групп в каждом из файлов. Панель «Проводник» позволяет быстро просматривать, выбирать, перемещать и систематизировать элементы в файлах.

В панели «Проводник» можно выполнять перечисленные ниже действия.

  • Открывать несколько файлов.
  • Создавать файлы, категории, объекты и группы, щелкнув правой кнопкой мыши и выбрав нужный пункт в контекстном меню.

Панели свойств и атрибутов

Отображают и позволяют редактировать свойства выбранных файлов, категорий, объектов, групп и кодов управления линиями.

Графический вид

Показывает, как символы элементов и комментарии будут отображаться в графических видах, позволяет выбирать и перемещать комментарии.

Примечание. Для панорамирования в графическом виде щелкните среднюю кнопку мыши и перетащите область в нужное положение. Для увеличения или уменьшения масштаба следует прокрутить колесико мыши.

Строка состояния

Отображает названия имена текущей категории и объекта, а также положение курсора в графическом виде.

См. также:

Общие сведения о Диспетчере определений объектов

Последовательность операций для Диспетчера определений объектов


Получение справки

В справочной системе предусмотрены различные способы поиска информации.

Опции
Содержание | Отображение всех разделов справки в виде древовидной структуры. Для просмотра щелкните название главы или раздела.
Поиск | Введите ключевое слово в поле поиска. Затем щелкните Разделы для поиска данного слова в разделах справки. Выберите раздел в результатах поиска и нажмите кнопку «Показать», чтобы его открыть. Искомое ключевое слово выделяется во всех разделах справки. См. ниже опцию «Подсвечивание результатов / Выключить подсвечивание».
Скрыть/показывать вкладки | Скрытие и отображение вкладок «Содержание» и «Поиск».
Назад | Просмотр предыдущего раздела.
Печать | Щелкните для открытия диалогового окна «Печать». Выберите опцию печати – только выделенный раздел или заголовок и все подразделы.
Меню «Параметры»
Остановить | Завершение поиска.
Обновить | Сброс отображения текущей страницы.
Параметры Интернета | Щелкните эту опцию для открытия диалогового окна «Свойства обозревателя», в котором можно задать настройки Интернета: безопасность, конфиденциальность, содержимое, соединения, программы и др.
Подсвечивание результатов / Выключить подсвечивание | Включение и выключение выделения ключевого слова в найденных разделах.

См. также:

Общие сведения о Диспетчере определений объектов


Отправить отзыв

Мы всегда стремимся предоставить наиболее полезную документацию. Если у вас есть замечания или предложения по усовершенствованию справки, примечаний к выпуску, обзоров, учебников или справочников последовательностей операций, незамедлительно обращайтесь к нам по адресу:
OSG_Documentation@Trimble.com

Все присланные замечания и предложения становятся собственностью компании Trimble Navigation Limited.


Управление файлами определений объектов (.fxl)

Файлы определений объектов (.fxl) содержат информацию приведенных ниже типов, систематизированную в собственном формате Диспетчера определений объектов.

  • Категории определений объектов
  • Определения объектов
  • Атрибуты объектов
  • Коды управления линиями
  • Группы определений объектов и кодов управления линиями
  • Символы и стили линий

См. также:

Создание файлов определений объектов (.fxl)

Открытие файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Ввод и редактирование свойств файла определений объектов (.fxl)

Свойства файла определений объектов (.fxl)

Создание шаблонов файлов определений объектов (.fxl)

Сохранение файлов определений объектов (.fxl)


Создание файлов определений объектов (.fxl)

Создание нового файла определений объектов (.fxl).

  1. Выполните одно из приведенных ниже действий.
    • Выберите «Файл > Создать файл».
    • Щелкните значок [image] на панели инструментов.

    В панели «Проводник» отображается значок новой папки с именем «Новый файл», также отобразится панель «Свойства файла».

  2. Щелкните требуемое поле и отредактируйте значение.

    Дополнительные инструкции см. в разделе «Свойства файла».

    Примечание. Максимальная длина «0» означает отсутствие ограничения.

  3. Завершив операции, выполните одно из приведенных ниже действий.
    • Выберите «Файл > Сохранить».
    • Щелкните значок [image] на панели инструментов.

    Отобразится диалоговое окно «Сохранить».

  4. В диалоговом окне «Сохранить» введите имя файла, выберите тип файла и место его хранения. Затем нажмите «OK».

В панели «Проводник» надпись «Новый файл» будет заменена введенными путем и именем файла.

См. также:

Управление файлами определений объектов (.fxl)

Открытие файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Ввод и редактирование свойств файла определений объектов (.fxl)

Свойства файла определений объектов (.fxl)

Создание шаблонов файлов определений объектов (.fxl)

Сохранение файлов определений объектов (.fxl)


Открытие файлов определений объектов (.fxl)

Процедура открытия файла определений объектов (.fxl)

  1. Выполните одно из приведенных ниже действий.
    • Выберите «Файл > Открыть».
    • Щелкните значок [image] на стандартной панели инструментов.

    Отобразится диалоговое окно «Открыть файл».

  2. В диалоговом окне «Открыть файл» найдите файл, который следует открыть, и нажмите «OK».

    Значок файла отобразится в панели «Проводник», и отобразится панель «Свойства файла».

    Примечания.
    - файл примеров данных FXL, предоставляемый с Feature Definition Manager, устанавливается в подпапке приложения в папке «Program Files». Однако при открытии программы в подпапке в папке «Мои документы» будет создана его вторая версия, которую можно открыть через меню «Файл». Рекомендуется использовать эту версию файла вместо исходной версии, сохраненной в подпапке приложения в папке «Program Files».
    - По умолчанию все файлы определения объектов (.fxl) открываются и сохраняются в Feature Definition Manager в формате последней версии, который совместим с Trimble Access и Survey Controller версий 12.40 и старше.

См. также:

Управление файлами определений объектов (.fxl)

Создание файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Ввод и редактирование свойств файла определений объектов (.fxl)

Свойства файла определений объектов (.fxl)

Создание шаблонов файлов определений объектов (.fxl)

Сохранение файлов определений объектов (.fxl)


Преобразование файла FCL в файл FXL

Процедура преобразования файла FCL в файл FXL

  1. Выберите «Файл > Преобразовать файл». Отобразится диалоговое окно «Преобразовать файл».
  2. Введите имя файла и путь к файлу .fcl, которые следует преобразовать, в поле «Выбор исходного файла» или нажмите кнопку [image] и перейдите к файлу .fcl.
  3. Введите имя файла и путь к целевому файлу .fxl в поле «Выберите файл назначения» или нажмите кнопку [image] и перейдите к файлу .fxl.
  4. Выберите язык, используемый в файле .fcl в списке «Выберите язык».
  5. Выберите версию формата .fxl, в которую следует преобразовать файл .fcl.
  6. Нажмите «OK».

    Значок нового созданного файла .fxl отобразится в панели «Проводник проекта».


Ввод и редактирование свойств файла определений объектов (.fxl)

Процедура ввода и редактирования свойств файла определений объектов (.fxl)

  1. На панели «Проводник» выберите файл, с которым будете работать.
  2. Выполните одно из приведенных ниже действий.
    • Выберите «Файл > Свойства».
    • Щелкните значок [image] на панели инструментов.

    Появится панель «Свойства файла».

  3. Щелкните требуемое поле и отредактируйте значение.

    Дополнительные инструкции см. в разделе «Свойства файла».

    Примечание. Максимальная длина «0» означает отсутствие ограничения.

  4. Завершив операции, выполните одно из приведенных ниже действий.
    • Выберите «Файл > Сохранить».
    • Щелкните значок [image] на панели инструментов.

    При первоначальной установке свойств нового файла отобразится диалоговое окно «Сохранить». В диалоговом окне «Сохранить» введите имя файла, выберите тип файла и место его хранения. Затем нажмите «OK».

См. также:

Управление файлами определений объектов (.fxl)

Создание файлов определений объектов (.fxl)

Открытие файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Свойства файла определений объектов (.fxl)

Создание шаблонов файлов определений объектов (.fxl)

Сохранение файлов определений объектов (.fxl)


Свойства файла определений объектов (.fxl)

Используйте эти опции для указания автора, описания, максимальной длинны некоторых полей, а также того, являются ли коды объектов только цифровыми. Они доступны в панели «Свойства файла».

Опции
Автор | Введите имя создателя файла.
Описание | Введите дополнительную информацию о файле.
Дата создания | Отображает доступную только для чтения дату создания файла.
Дата изменения | Отображает доступную только для чтения дату последнего изменения файла.
Задает использование только числовых кодов объектов | Нет - выберите эту опцию, чтобы разрешить буквенно-цифровые коды. Да - выберите эту опцию, чтобы использовать только числовые коды.
Максимальная длина имени атрибута | Введите значение максимального числа символов, разрешенных в поле «Имя» атрибута. Примечание. Максимальная длина «0» означает отсутствие ограничения.
Максимальная длина имени категории | Введите значение максимального числа символов, разрешенных в поле «Имя» категории.
Максимальная длина имени объекта | Введите значение максимального числа символов, разрешенных в поле «Имя» элемента.
Максимальная длина топокода | Введите значение максимального числа символов, разрешенных в поле «Код» объекта.
Максимальное число кодов в группе | Введите значение максимального числа кодов объектов или кодов управления, разрешенных в группе. Это зависит от типа полевого устройства, которое вы планируете использовать.

См. также:

Управление файлами определений объектов (.fxl)

Создание файлов определений объектов (.fxl)

Открытие файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Ввод и редактирование свойств файла определений объектов (.fxl)

Создание шаблонов файлов определений объектов (.fxl)

Сохранение файлов определений объектов (.fxl)


Создание шаблонов файлов определений объектов (.fxl)

Можно создать один или несколько шаблонов с наиболее часто используемыми данными объектов. Это позволяет экономить время и обеспечить согласованность проектов.

Процедура создания файла шаблона

  1. Откройте существующий файл, похожий на создаваемый шаблон, либо создайте новый файл.

    Примечание. Инструкции к приведенным далее шагам см. в соответствующих разделах справки.

  2. Задайте необходимые свойства файла.
  3. Создайте, отредактируйте и удалите соответствующие категории, объекты, атрибуты, коды управления и группы.
  4. Создайте, отредактируйте и удалите соответствующие комментарии и символы.
  5. Выберите «Файл > Сохранить как». Отобразится диалоговое окно «Сохранить как».
  6. В диалоговом окне «Сохранить как» выполните приведенные ниже действия.
    1. Введите имя файла.
    2. Выберите тип файла.
    3. Выберите папку, в которой следует сохранить файл.
    4. Нажмите «OK».

См. также:

Управление файлами определений объектов (.fxl)

Создание файлов определений объектов (.fxl)

Открытие файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Ввод и редактирование свойств файла определений объектов (.fxl)

Свойства файла определений объектов (.fxl)

Сохранение файлов определений объектов (.fxl)


Сохранение файлов определений объектов (.fxl)

Файл определений объектов (.fxl) следует сохранять как можно быстрее и чаще.

Предупреждение. Изменения не сохраняются автоматически.

Процедура сохранения файла определений объектов (.fxl)

  1. Выполните одно из приведенных ниже действий.
    • Выберите «Файл > Сохранить».
    • Щелкните значок [image] на панели инструментов.

    Если файл уже сохранялся, то сохранение происходит без отображения диалогового окна. Если файл ранее не сохранялся, отобразится диалоговое окно «Сохранить как».

  2. При отображении диалогового окна «Сохранить» выполните приведенные ниже действия.
    1. Введите имя файла.
    2. Выберите тип файла.
    3. Выберите папку, в которой следует сохранить файл.
    4. Нажмите «OK». При сохранении файла надпись «Создать файл» в панели «Проводник» заменяется указанным именем и путем к файлу.

Процедура сохранения файла определений объектов (.fxl) с новым именем

  1. Выберите «Файл > Сохранить как». Отобразится диалоговое окно «Сохранить как».
  2. В диалоговом окне «Сохранить как» выполните приведенные ниже действия.
    1. Введите имя файла.
    2. Выберите тип файла.
    3. Выберите папку, в которой следует сохранить файл.
    4. Нажмите «OK». Новое имя файла отобразится в панели «Проводник».

См. также:

Управление файлами определений объектов (.fxl)

Создание файлов определений объектов (.fxl)

Открытие файлов определений объектов (.fxl)

Преобразование файла FCL в файл FXL

Ввод и редактирование свойств файла определений объектов (.fxl)

Свойства файла определений объектов (.fxl)

Создание шаблонов файлов определений объектов (.fxl)


Загрузка и импорт данных определений объектов

Данные определений объектов можно загрузить непосредственно с полевого устройства, также можно импортировать сохраненные данные определений объектов из файла.

Примечание. Для импорта или загрузки данных файл должен быть открыт. Импортируемые и загружаемые данные сохраняются в текущем файле.

Процедура загрузки данных определений объектов с полевого устройства

  1. Подключите полевое устройство к компьютеру.
  2. Выберите «Файл > Импорт». Отобразится диалоговое окно «Импорт файла».
  3. Нажмите «Загрузить с устройства».
  4. Выберите полевое устройство в списке «Название устройства».
  5. Выберите программу в списке «Приложение».
  6. Нажмите «OK». Загруженные данные отобразятся в файле в панели «Проводник».

Процедура импорта данных определений объектов из файла

  1. Выберите «Файл > Импорт». Отобразится диалоговое окно «Импорт файла».
  2. Нажмите «Импорт из файла».
  3. В поле «Исходный файл» введите имя и путь к файлу или нажмите кнопку [image] и выберите требуемый файл.
  4. Выберите программу в списке «Приложение».
  5. Нажмите «OK». Импортированные данные отобразятся в файле в панели «Проводник».

См. также:

Опции импорта и загрузки

Форматы импорта и экспорта

Импорт файлов словарей данных (.ddf)


Опции импорта и загрузки

Эти опции используются для импорта внешних данных из другого приложения или полевого устройства. Они доступны в диалоговом окне «Файл импорта».

Диспетчер определений объектов использует собственный формат файлов .fxl, обеспечивающий эффективное хранение и систематизацию определений объектов. Кроме того, импортер Диспетчера определений объектов обеспечивает его совместимость с множеством других форматов.

Опции
Исходный файл | Укажите путь и имя импортируемого файла, либо нажмите кнопку [image] и выберите файл в проводнике.
Тип файла | Показывает формат выбранного файла.
Импорт из файла | Щелкните эту опцию, чтобы выбрать файл на компьютере или в сети.
Загрузить с устройства | Щелкните эту опцию, чтобы выбрать файл на подключенном полевом устройстве.
Название устройства | Отображает название подключенного полевого устройства.
Приложение | Выберите полевую программу, для которой предназначен данный файл объектов.

См. также:

Загрузка и импорт данных определений объектов

Форматы импорта и экспорта

Импорт файлов словарей данных (.ddf)


Форматы импорта и экспорта

Диспетчер определений объектов позволяет осуществлять импорт и экспорт данных различных программ в приведенных ниже форматах.

Импорт | Формат файла | Экспорт
 | .fal - файл библиотеки объектов и атрибутов |
 | .ddf - файл словаря данных |
 | .csv - простой текстовый файл |
 | .lst - файл списка кодов Nikon |
 | .xml - файл Geodatabase |

См. также:

Загрузка и импорт данных определений объектов

Импорт файлов словарей данных (.ddf)

Опции импорта и загрузки


Импорт файлов словарей данных (.ddf)

При использовании программы Trimble® GPS Pathfinder® вы можете импортировать файлы словарей данных (.ddf) из Редактора словаря данных. Импорт данных объектов в этом формате избавляет вас от необходимости повторного создания атрибутов в Диспетчере определений объектов.

При импорте файла словаря данных все объекты-линии и объекты-области преобразовываются в объекты-точки, но определения атрибутов остаются неизменными.

Если объект .ddf с таким именем уже существует в библиотеке объектов, выполните приведенные ниже действия.

  • Атрибуты в версии .ddf заменяют атрибуты в существующем объекте.
  • Стили точек, стили линий и шаблоны комментариев для существующего объекта остаются неизменными, поскольку файлы .ddf этих данных не содержат.

Если объект .ddf не существует в библиотеке объектов, он будет отображаться со знаком вопроса, поскольку стиль точки не задан.

В противном случае объекты, импортированные из файла словаря данных, будут по сути такими же, как объекты, созданные в Диспетчере определений объектов.

См. также:

Загрузка и импорт данных определений объектов

Опции импорта и загрузки

Форматы импорта и экспорта


Импорт файлов Geodatabase (.xml)

При импорте определений объектов из файла geodatabase (.xml), обратите внимание на следующее:

  • Файлы geodatabase не поддерживают коды определения объектов. При импорте файла geodatabase в Feature Definition Manager вместо кодов определений используются имена определений. Имена или коды можно изменить после импорта.
  • Файлы geodatabase не поддерживают пробелы в именах определения объектов. При импорте файла geodatabase в Feature Definition Manager вместо пробелов в имена и коды определений вставляется символ подчеркивания. Имена или коды можно редактировать после импорта.
  • Файлы geodatabase не поддерживают категории. При импорте файла geodatabase в Feature Definition Manager все импортированные определения объектов включаются в категорию «Прочее». При необходимости после импорта можно сгруппировать определения объектов в новые или существующие категории.
  • Файлы geodatabase не поддерживают стандартные значения атрибутов, т.е. линии и символы. При необходимости можно добавить эти свойства после импорта.

См. также:

Загрузка и импорт данных определений объектов

Опции импорта и загрузки

Форматы импорта и экспорта


Работа с категориями определений объектов

Категории можно использовать для упорядочивания определений объектов в наборы похожих определений. Категории позволяют быстро выбирать только определения объектов, необходимые для конкретного вида работы при подготовке к сбору полевых данных.

При выборе категории в панели «Проводник» в главном окне отобразится список определений объектов в данной категории.

См. также:

Создание и редактирование категорий определений объектов


Создание и редактирование категорий определений объектов

Процедура создания объекта

  1. В панели «Проводник» щелкните правой кнопкой мыши файл, в который требуется добавить новую категорию и выберите команду «Создать > Создать категорию». Отобразится панель «Имя» для новой категории.
  2. Введите имя для новой категории в поле «Имя».
  3. Щелкните в любом месте панели «Проводник». Новая категория отобразится в панели «Проводник».

Процедура редактирования имени категории определений объектов

  1. В панели «Проводник» щелкните имя категории, которую требуется изменить. Отобразится панель «Имя» для категории.
  2. В поле «Имя» введите новое имя категории.
  3. Щелкните в любом месте панели «Проводник». Категория с новым именем отобразится в панели «Проводник».

См. также:

Работа с категориями определений объектов


Работа с определениями объектов

Определения объектов используются для представления типов объектов, которые могут существовать в полевых условиях (например тротуаров, столбов и т.п.). Диспетчер определений объектов содержит набор стандартных определений объектов, которые вы можете использовать в качестве базовых при создании собственной библиотеки определений объектов.

Каждое определение объекта в файле должно иметь уникальное имя и код, но вы можете одновременно открывать несколько файлов, содержащих определение объектов с одинаковыми именами и (или) кодами.

На панели инструментов также имеется поле поиска, в котором вы можете ввести имя определения объекта, кода управления или группы. Нажатием [Enter] производится поиск и выбор имени в панели «Проводник».

Существует два типа определений объектов

  • Объект-точка используется для определения одного объекта, такого как дерево или столб. Определение объекта-точки представляется значком [image] в панели «Проводник».
  • Объект-линия состоит из двух или нескольких точек, определяющих линию, например забор или дорожку. Определение объекта-линии представляется значком [image] в панели «Проводник». К объектам-линиям также могут относиться коды управления линиями, использующиеся для дополнительного определения линейных объектов (например добавления линий, кривых и дуг между точками).

См. также:

Создание и редактирование определений объектов

Опции определений объектов


Создание и редактирование определений объектов

Процедура создания определения объекта

  1. В панели «Проводник» щелкните файл, в который требуется добавить новый объект.
  2. Выполните одно из приведенных ниже действий.
    • Выберите пункты меню «Правка > Создать > Новое определение объекта».
    • Щелкните значок [image] на панели инструментов «Создать».

    Отобразится диалоговое окно «Новое определение объекта».

    Примечание. Сведения для приведенных ниже шагов см. в разделе «Параметры определений объектов».

  3. Введите соответствующие значения в поля «Имя» и «Код».
  4. Выберите соответствующие пункты в списках «Категория», «Тип», «Цвет» и «Слой».
  5. Установите флажки «Включить в поверхность», «Структурная линия в поверхности» и «Обратное направление», если применимо. (Пункты «Структурная линия в поверхности» и «Обратное направление» доступны только при создании определения объекта-линии.)
  6. Завершив операции, нажмите «OK». Значок нового определения объекта отобразится в панели «Проводник» под выбранной категорией.

Процедура редактирования существующего определения объекта

  1. В панели «Проводник» щелкните имя определения объекта, которое требуется изменить. Отобразится панель «Свойства определения объекта».
  2. Щелкните любое из полей в панели «Свойства определения объекта» для изменения свойств. Подробные сведения см. в разделе «Параметры определений объектов».
  3. Для подтверждения изменений нажмите клавишу «TAB» или выберите другой пункт в панели «Проводник».

См. также:

Работа с определениями объектов

Параметры определений объектов


Параметры определений объектов

Используйте эти параметры, чтобы задать свойства определений объектов. Они доступны в диалоговом окне «Новое определение объекта» и в панели «Свойства определения объекта».

Параметры

Имя

Введите уникальный идентификатор определения объекта. Не допускается наличие двух определений объектов с одинаковыми именами в одном файле.

Код

Введите уникальную аббревиатуру имени определения объекта.

Категория

Выберите категорию, в которой будет храниться определение объекта.

Тип

Объект-точка – выберите данный пункт для создания определения объекта-точки. Объект-точка используется для обозначения одного объекта, такого как дерево или столб.

Объект-линия – выберите данный пункт для создания определения объекта-линии. Объект-линия состоит из двух или нескольких точек, определяющих линию, например забор или дорожку.

Слой

Выберите соответствующий слой для определения объекта, если для файла были ранее определены слои. Или выберите один из приведенных ниже пунктов.

0 – выберите этот пункт, чтобы оставить новый объект на слое по умолчанию.

Точки – выберите этот пункт, чтобы поместить объект-точку на один слой с другими определениями объектов-точек.

<<Создать слой>> – выберите этот пункт для отображения диалогового окна «Создать слой», в котором можно определить перечисленные ниже свойства нового слоя.

  • Имя слоя
  • Цвет
  • Стиль линии

    Если требуется импортировать стиль линии, выберите пункт <<Импорт стилей линий>>. Отобразится диалоговое окно «Диспетчер стилей линий». В этом диалоговом окне можно импортировать и удалять стили линий. Инструкции см. в разделе «Работа со стилями линий».

Цвет

По слою – выберите этот пункт, чтобы объект унаследовал свой цвет отображения от слоя, на котором он находится.

(Цвет) – выберите определенный цвет для отображения определения объекта в графическом виде.

Стиль линии

Выберите подходящий стиль линии.

Если требуется импортировать стиль линии, выберите пункт <<Импорт стилей линий>>. Отобразится диалоговое окно «Диспетчер стилей линий». В этом диалоговом окне также можно удалять стили линий. Инструкции см. в разделе «Работа со стилями линий».

Данный пункт доступен только при создании или редактировании определения объекта-линии.

Масштаб стиля линии

Введите масштабный коэффициент для символов, используемых для представления линии.

Данный пункт доступен только при создании или редактировании определения объекта-линии.

Включить в поверхность

Установите этот флажок, чтобы объект использовался в операциях создания поверхностей после обработки кодов объектов в другом приложении.

См. также:

Работа с определениями объектов

Создание и редактирование определений объектов

Работа со стилями линий


Работа со стилями линий

Диалоговое окно «Менеджер стилей линий» отображается, если при создании или изменении линии выбрана опция <<Импорт стилей линий>>.

Импорт стилей линий

  1. Выберите соответствующие параметры «Единицы длины» и «Ссылка на единицы».
  2. Затем нажмите кнопку «Обзор», чтобы найти файл стиля линии, из которого будет произведен импорт стилей линий.
  3. В списке справа выберите стили линии, которые необходимо импортировать, и нажмите кнопку «Переместить (<)», чтобы переместить выбранные элементы в список слева, или нажмите кнопку «Переместить (<<)», чтобы переместить все элементы из правого списка в левый. В списке слева отображаются все стили линий, доступные в проекте.
  4. Завершив операции, нажмите «OK». Импортированные стили линий теперь будут доступны для выбора в списке «Стиль линии».

Удаление стилей линий

  1. В списке слева выберите стили линий для удаления.
  2. Нажмите кнопку «Удалить (X)».
  3. Завершив операции, нажмите «OK».

См. также:

Опции определений объектов

Опции смещенных объектов-линий


Работа с символами объектов

Объекты могут отображаться как символы в графических видах в офисной программе обработки геодезических данных. Можно указать, какие символы используются с каждым определением объекта.

См. также:

Назначение, редактирование и удаление символов объектов

Опции символов объектов


Назначение, редактирование и удаление символов объектов

Процедура назначения символа определению объекта

  1. На панели «Проводник» щелкните правой кнопкой мыши определение объекта, которому необходимо назначить символ, и выберите «Создать > Символ». Отобразится диалоговое окно «Символ».
  2. Заполните поля, как описано в разделе «Опции символов объектов».
  3. Завершив операции, нажмите «OK». Новые назначенные символы отобразятся в списке «Линии и символы».

Процедура изменения символа

  1. На панели «Проводник» щелкните определение объекта, для которого необходимо изменить символ.
  2. В списке «Линии и символы», дважды щелкните символ, который необходимо отредактировать. Отобразится диалоговое окно «Символ».
  3. Заполните поля, как описано в разделе «Опции символов объектов».
  4. Завершив операции, нажмите «OK».

Процедура удаления символа

  1. На панели «Проводник» щелкните определение объекта, из которого необходимо удалить символ.
  2. В списке «Линии и символы» щелкните правой кнопкой мыши символ, который необходимо удалить.
  3. В контекстном меню выберите опцию «Удалить».

См. также:

Работа с символами объектов

Опции символов объектов


Опции символов объектов

Используйте эти опции, отображающиеся в диалоговом окне «Символ», чтобы определить свойства символа.

Опции

Имя

Введите идентификатор для данного символа.

Описание

Введите общие комментарии для данного символа.

Символ

Выберите символ для представления объекта.

Если необходимо импортировать новый символ, выберите опцию <<Импорт символов>>. Отобразится диалоговое окно «Диспетчер символов». В этом диалоговом окне можно импортировать и удалять стили линий. Инструкции см. в разделе «Работа с символами».

Цвет

По слою - выберите эту опцию, чтобы использовать цвет слоя, на котором размещены коды объектов в программе обработки геодезических данных.

По Блокам / Объектам - выберите эту опцию, чтобы использовать цвет слоя, на котором размещен объект.

(Цвет) - выберите необходимый цвет.

Размещение

Разворот

Фиксированное значение - выберите эту опцию, чтобы открыть окно «Значение», в котором можно ввести угол разворота символа. Разворот производится против часовой стрелки.

Атрибут - выберите эту опцию, чтобы открыть список «Имя атрибута», в котором можно выбрать необходимое имя атрибута. Символ будет развернут на величину (в градусах), определенную в атрибуте.

Размер и масштаб символа

Задание размеров

Местность - выберите эту опцию для масштабирования символа в соответствии с конкретным размером местности исходя из фиксированного значения или атрибута.

Бумага - выберите эту опцию для масштабирования символа в соответствии с масштабом чертежа, заданным для вашего проекта, исходя из фиксированного значения или атрибута.

Метод ввода

Фиксированное значение - выберите эту опцию, чтобы открыть поле «Значение», в котором можно ввести размер символа.

Если в групповом поле «Задание размеров» вы выбрали «Местность», символ масштабируется в соответствии с размером местности исходя из введенного вами значения. Например, если вы ввели 1 метр, размер символа на местности будет 1 метр.

Если в групповом поле «Задание размеров» вы выбрали «Бумага», символ масштабируется в соответствии с масштабом чертежа, заданным для вашего проекта, исходя из введенного вами значения. Например, если вы ввели 1 миллиметр и масштаб чертежа вашего проекта равен 100, размер символа на местности будет 0,1 метра (1 мм x 100). Масштаб чертежа по умолчанию, используемый для отображения символа в «Диспетчер определений объектов», равен 100; однако масштаб чертежа вашего проекта может быть другим.

Атрибут - выберите эту опцию, чтобы открыть список «Имя атрибута», в котором можно выбрать необходимое имя атрибута. Размер символа будет установлен исходя из значения, заданного для атрибута.

Если в групповом поле «Задание размеров» вы выбрали «Местность», символ масштабируется в соответствии с размером местности исходя из значения, заданного для выбранного атрибута. Например, если вы выбрали атрибут, значение которого равно 1, а ваша единица отображения - метры, размер символа на местности будет 1 метр.

Если в групповом поле «Задание размеров» вы выбрали «Бумага», символ масштабируется в соответствии с масштабом чертежа, заданным для вашего проекта, исходя из значения, заданного для выбранного атрибута. Например, если вы выбрали атрибут, значение которого равно 1, а масштаб чертежа вашего проекта равен 100, размер символа будет составлять 0,1 метра (1 мм x 100). Масштаб чертежа по умолчанию, используемый для отображения символа в «Диспетчер определений объектов», равен 100; однако масштаб чертежа вашего проекта может быть другим.

Примечание. Чтобы изменить единицы отображения, щелкните кнопку «Изменить свойства». Выбранные здесь единицы отображения должны соответствовать единицам отображения, используемым в проекте.

См. также:

Работа с символами объектов

Назначение, редактирование и удаление символов объектов

Работа с символами


Работа с символами

При выборе опции <<Импорт символов>> во время работы с символом отобразится диалоговое окно «Диспетчер символов».

Импорт или удаление символов

  1. В диалоговом окне «Диспетчер символов» щелкните кнопку [image] и перейдите к файлу, содержащему символ(ы), который требуется импортировать.

    Символы, используемые по умолчанию, находятся в установленном файле:
    C:\Program Files\Trimble\Feature Definition Manager\PEditor\Symbols.sym
  1. Выполните одно из приведенных ниже действий.
    • Для импорта всех символов из выбранного файла щелкните кнопку << .
    • Для импорта одного символа из выбранного файла выберите его в правом списке и щелкните кнопку < .
    • Для удаления символа выберите его в левом списке и щелкните кнопку X .
  2. Завершив операции, нажмите «OK».

См. также:

Опции символов объектов


Работа со смещенными линиями объектов

Если требуется создать одну или несколько смещенных линий для объекта-линии, в отличие от одной центральной линии, можно назначить смещенные линии определению объекта-линии. Например, может потребоваться добавить две смещенные линии к объекту-линии для тротуара: одну, отстоящую на 2 единицы влево от центральной линии тротуара, для определения левого края, а другую, отстоящую на 2 единицы вправо от центральной линии тротуара, для определения правого края. В этом случае можно добавить две смещенных линии в определение объекта: оду с использованием значения сдвига в плане 2, и одну с использованием значения сдвига в плане -2. Кроме того, можно использовать различные цвета и стили для требуемых смещенных линий.

Примечание. При добавлении в определение объекта смещенной линии центральная линия больше не отображается.

См. также:

Назначение, редактирование и удаление смещенных линий объектов

Опции смещенных объектов-линий


Назначение, редактирование и удаление смещенных линий объектов

Процедура назначения смещенной линии определению объекта-линии.

  1. В панели «Проводник» щелкните правой кнопкой мыши определение объекта, которому необходимо присвоить смещенную линию, и выберите «Создать > Создать линию». Отобразится диалоговое окно «Линия».
  2. Заполните поля, как описано в разделе «Опции смещенных линий объектов».
  3. Завершив операции, нажмите «OK». Новые назначенные смещенные линии отобразятся в списке «Линии и символы».

Процедура изменения смещенной линии.

  1. В панели «Проводник» щелкните определение объекта, для которого необходимо изменить смещенную линию.
  2. В списке «Линии и символы» дважды щелкните смещенную линию, которую необходимо отредактировать. Отобразится диалоговое окно «Линия».
  3. Заполните поля, как описано в разделе «Опции смещенных линий объектов».
  4. Завершив операции, нажмите «OK».

Процедура удаления смещенной линии

  1. В панели «Проводник» щелкните определение объекта, из которого необходимо удалить смещенную линию.
  2. В списке «Линии и символы» щелкните правой кнопкой мыши смещенную линию, которую необходимо удалить.
  3. В контекстном меню выберите опцию «Удалить».

См. также:

Работа со смещенными линиями объектов

Опции смещенных линий объектов


Опции смещенных линий объектов

Используйте эти опции, отображающиеся в диалоговом окне «Линия», чтобы определить свойства смещенной линии объекта.

Опции

Имя

Введите идентификатор линии со смещением.

Описание

Введите общие комментарии о линии со смещением

Стиль

Выберите подходящий стиль линии.

Если требуется импортировать стиль линии, выберите опцию <<Импорт стилей линий>>. Отобразится диалоговое окно «Менеджер стилей линий». В этом диалоговом окне можно импортировать и удалять стили линий. Инструкции см. в разделе «Работа со стилями линий».

Масштаб

Введите масштабный коэффициент для символов, используемых для представления линии.

Цвет

По слою - выберите эту опцию, чтобы использовать цвет слоя, на котором размещены коды объектов в программе обработки геодезических данных.

По Блокам / Объектам - выберите эту опцию, чтобы использовать цвет слоя, на котором размещен объект.

(Цвет) - выберите подходящий цвет.

Сдвиг в плане

Введите значение сдвига линии в плане от центральной линии объекта.

Эта опция позволяет создать дополнительную линию.

Сдвиг по высоте

Введите значение сдвига линии по высоте от центральной линии объекта.

Эта опция позволяет создать дополнительную линию.

Тип смещения

На земной поверхности - выберите эту опцию, чтобы использовать фактические единицы проекта для значений сдвига в плане и по высоте.

Лист - выберите эту опцию, чтобы использовать единицы листа бумаги для значений сдвига в плане и по высоте.

См. также:

Работа со смещенными линиями объектов

Назначение, редактирование и удаление смещенных линий объектов

Работа со стилями линий


Работа с атрибутами объектов

Атрибуты объектов представляют собой назначенные в описаниях объектов характеристики, используемые для дальнейшего описания объектов. Атрибуты объектов можно использовать в перечисленных ниже целях.

  • Предварительное задание часто встречающихся характеристик, чтобы полевые партии могли ими быстро воспользоваться в дальнейшем. Например, для объекта «дерево» можно добавить следующие атрибуты: порода, высота, обхват и состояние. Для каждого объекта-дерева, зарегистрированного в полевых условиях, можно назначить собственные значения этих атрибутов.
  • Контроль типа информации, которую можно или требуется собрать об объектах в полевых условиях. Например, если вам требуется символ для каждого регистрируемого дерева, добавьте атрибут символа к объекту дерева и задайте его как «Нужный». Полевое устройство будет выдавать запрос на указание символа для каждого регистрируемого объекта.

См. также:

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Назначение и редактирование атрибутов объектов

Процедура назначения атрибута определению объекта

  1. На панели «Проводник» щелкните правой кнопкой мыши определение объекта, которому необходимо присвоить атрибут, и выберите «Создать > Атрибут > (тип атрибута)». Отобразится диалоговое окно для атрибута выбранного типа.

    Описания всех доступных типов атрибутов и ссылки на темы, описывающие порядок ввода свойств для них в диалоговом окне для соответствующего типа атрибутов, см. в разделе «Опции атрибутов объектов».

  2. Завершив ввод свойств в диалоговом окне для выбранного типа атрибутов, нажмите «OK». Только что назначенный атрибут отобразится в списке «Атрибуты» для соответствующего определения объекта в главном окне.

Процедура редактирования существующего атрибута

  1. На панели «Проводника» щелкните определение объекта, для которого необходимо изменить атрибут.
  2. В списке «Атрибуты», дважды щелкните атрибут, который необходимо отредактировать. Отобразится диалоговое окно для выбранного типа атрибутов.
  3. Заполните поля, как описано в разделе «Опции атрибутов объектов».
  4. Завершив операции, нажмите «OK».

См. также:

Работа с атрибутами объектов

Опции атрибутов объектов


Опции атрибутов объектов

Приведенные ниже опции позволяют добавлять атрибуты, которые полевые партии могут выбирать при регистрации объектов в поле. Они становятся доступны в контекстном меню при щелчке объекта правой кнопкой мыши и выборе «Создать > Создать атрибут».

Опции

Число

Выберите эту опцию для установки атрибутов с числовыми значениями, таких как обхват и высота деревьев или концентрация загрязнений в конкретных местах.

В поля числовых атрибутов можно вводить только целые и десятичные числа.

Текст

Выберите эту опцию, если необходимо регистрировать атрибуты с буквенно-цифровыми символами, такие как название улицы или фамилия владельца объекта.

Можно вводить числа в текстовый атрибут, однако если данный атрибут будет всегда числовым, используйте числовой атрибут.

Дата

Выберите эту опцию, если необходимо регистрировать атрибуты в стандартных форматах данных, таких как дата установки опор линий электропередач.

Время

Выберите эту опцию, если необходимо регистрировать атрибуты в формате времени, например время регистрации объекта в часах и минутах.

Список

Выберите эту опцию, если необходимо регистрировать атрибуты путем выбора из списка опций, например, выбрать геодезический знак из пяти возможных типов, доступных в проекте.

Файл

Выберите эту опцию, если необходимо регистрировать атрибуты файла.

Фото

Выберите эту опцию, если необходимо регистрировать атрибуты фотоснимка.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов


Атрибут объекта: числовые опции

Используйте эти опции для определения атрибутов, состоящих из числовых значений. Они доступны в диалоговом окне «Число».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут невозможно указать на полевом устройстве; его следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

Значение по умолчанию

Введите наиболее часто используемое значение; оно автоматически отобразится в поле атрибута.

Формат полевого устройства

Минимальное значение

Введите наименьшее допустимое числовое значение для данного атрибута.

Максимальное значение

Введите наибольшее допустимое числовое значение для данного атрибута.

Число десятичных разрядов

Введите число десятичных разрядов, допустимое справа от десятичной запятой. Введите значение 0, чтобы разрешить ввод только целых чисел.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции целых чисел.

Используйте эти опции для определения атрибутов, представленных целочисленными значениями. Они доступны в диалоговом окне «Целое число».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут невозможно указать на полевом устройстве; его следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

Значение по умолчанию

Введите наиболее часто используемое значение; оно автоматически отобразится в поле атрибута.

Формат полевого устройства

Минимальное значение

Введите наименьшее допустимое целочисленное значение для данного атрибута.

Максимальное значение

Введите наибольшее допустимое целочисленное значение для данного атрибута.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции текста

Эти опции используются для определения атрибутов текста, состоящего из строк букв, чисел и других вводимых символов. Они доступны в диалоговом окне «Текст».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут нельзя задавать на полевом устройстве, а следует вводить в файле определений объектов.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

Значение по умолчанию

Введите наиболее часто используемое значение; оно автоматически отобразится в поле атрибута. Если значение по умолчанию не введено, этот атрибут будет первоначально иметь пустое значение (значение отсутствует).

Максимальная длина

Введите максимальное количество символов, которые можно ввести (до 100 символов). В это поле необходимо ввести значение, по умолчанию задано 30.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции даты

Используйте эти опции для определения формата атрибута даты. Они доступны в диалоговом окне «Дата».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут нельзя задавать в полевых условиях, а следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если данный атрибут необходимо ввести при работе в полевых условиях.

Формат

Выберите в списке формат даты.

Примечание. Для экспорта данных в один из имеющихся ГИС-форматов экспорта заданный для атрибутов формат даты должен быть таким же, как на компьютере с ГИС-программой. При импорте файлов многие ГИС-системы проверяют установленные на компьютере параметры даты, и предполагается, что даты в файлах содержатся в том же формате, что задан параметрами на компьютере. Если параметры отличаются, могут быть получены нулевые значения в ГИС-программе.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции времени

Используйте эти опции, чтобы задать формат атрибута времени. Они доступны в диалоговом окне «Время».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут невозможно указать на полевом устройстве; его следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

Формат

Выберите в списке формат времени.

Примечание. Для экспорта данных в один из имеющихся ГИС-форматов экспорта заданный для атрибутов формат даты должен быть таким же, как на компьютере с ГИС-программой. При импорте файлов многие ГИС-системы проверяют установленные на компьютере параметры даты, и предполагается, что даты в файлах содержатся в том же формате, что задан параметрами на компьютере. Если параметры отличаются, могут быть получены нулевые значения в ГИС-программе.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции списка

Эти опции используются для определения атрибутов, требующих ряда стандартных значений, доступных для выбора. Они доступны в диалоговом окне «Список».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут невозможно указать на полевом устройстве; его следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

Элементы списка

При помощи кнопок создайте список, из которого можно будет выбирать опции.

Вверх - нажмите эту кнопку, чтобы переместить выделенный элемент вверх в списке.

Вниз - нажмите эту кнопку, чтобы переместить выделенный элемент вниз в списке.

По умолчанию - нажмите эту кнопку, чтобы выделенный элемент появлялся в списке, если не будет выбран какой-либо другой элемент.

Добавить - нажмите эту кнопку, чтобы вставить в список новый элемент. Затем введите данные элемента.

Удалить - нажмите эту кнопку, чтобы удалить элемент из списка.

Примечание. Для изменения элемента списка выберите его в меню «Элементы списка» и введите новое имя.

По умолчанию

Введите наиболее часто используемое значение; оно автоматически отобразится в поле атрибута. Если значение по умолчанию не введено, этот атрибут будет первоначально иметь пустое значение (значение отсутствует).

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции файла

Используйте эти опции для определения атрибутов файлов. Они доступны в диалоговом окне «Файл».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут невозможно указать на полевом устройстве; его следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Атрибут объекта: опции фотоснимков

Используйте эти опции для определения атрибутов фотоснимков. Они доступны в диалоговом окне «Фото».

Опции

Имя

Введите идентификатор для атрибута.

Описание

Введите общие комментарии для атрибута.

Это поле необязательное и не используется при работе в полевых условиях.

Режим ввода

Только для офисного использования - выберите эту опцию, если атрибут невозможно указать на полевом устройстве; его следует вводить на компьютере.

Факультативный - выберите эту опцию, если пользователь может выбрать, следует ли указывать данный атрибут.

Нужный - выберите эту опцию, если атрибут должен быть указан с допустимым значением.

Автогенерация - выберите эту опцию, если атрибут должен представлять собой фотоснимок, сделанный устройством.

Автогенерация - только чтение - выберите данную опцию, если атрибут должен представлять собой фотоснимок, сделанный устройством и не предназначенный для изменения.

См. также:

Работа с атрибутами объектов

Назначение и редактирование атрибутов объектов

Опции атрибутов объектов


Работа с кодами управления линиями

Геодезисты могут назначать точкам коды управления линиями во время сбора полевых данных для указания свойств соответствующих им объектов-линий. Например, они могут назначить точке код управления линией для указания начала и окончания объекта-линии. Во время обработки кодов объектов в офисной программе обработки геодезических данных коды управления линиями изменяют объекты-линии в соответствии с инструкциями кодов.

Примечание. Можно изменять стандартный список имеющихся кодов управления, но невозможно изменять действие, выполняемое каждым из них.

См. также:

Создание и редактирование кодов управления линиями

Опции кодов управления линиями


Создание и редактирование кодов управления линиями

Процедура создания кода управления линиями

  1. Выполните одно из приведенных ниже действий.
    • Выберите «Файл > Создать > Создать код управления линиями».
    • Щелкните правой кнопкой мыши в панели проводника и выберите «Создать > Создать код управления линиями».
    • Щелкните значок i_new control code на панели инструментов.

    Отобразится диалоговое окно «Управляющий код линии».

    Примечание. Полное описание всех опций, доступных в диалоговом окне «Управляющий код линии» см. в разделе «Опции кодов управления линиями».

  2. В поле «Имя» введите идентификатор кода.
  3. В поле «Код» введите аббревиатуру кода.
  4. В списке «Все действия» выберите действие, которое следует выполнять для данного кода. Над ним в поле «Выбранное действие» отображается информация о том, как данный код изменяет объект.
  5. Нажмите «OK».

Процедура редактирования существующего кода управления линиями

  1. В панели «Проводник» выберите код, который следует отредактировать. В главном окне отобразится окно «Свойства кодов управления линиями».
  2. Щелкните поля «Имя» и «Код» и внесите необходимые изменения.

    Примечание. Невозможно изменить действие для существующего кода управления линиями.

  3. Для подтверждения изменений нажмите клавишу [TAB] или выберите другую опцию в панели «Проводник».

См. также:

Работа с кодами управления линиями

Опции кодов управления линиями


Опции кодов управления линиями

Эти опции используются для создания и изменения кодов управления. Они доступны в диалоговом окне «Создать код управления линиями».

Опции

Имя

Введите идентификатор для кода управления.

Код

Введите аббревиатуру кода управления линиями, которая будет использоваться при работе в полевых условиях.

Выбранное действие

Отображает информацию о том, как выбранный код управления изменяет объект.

Все действия

Начало линии

Выберите это действие, чтобы начать новую последовательность соединения линии. Предыдущая последовательность соединения с таким же кодом заканчивается.

Используется для предотвращения соединения точки с предыдущей точкой с таким же кодом и для начала новой последовательности соединения.

В некоторых приложениях этот код управления не требуется для начала новой линии, если объекты-линии с одинаковым именем соединяются автоматически.

Примечание. Использование опции «Начало линии» дает такие же результаты, что и опция «Конец линии».

Конец линии

Выберите это действие, чтобы закончить последовательность соединения линии.

Используется для предотвращения соединения линией точки с кодом управления «Конец линии» со следующей точкой с таким же кодом объекта.

Соединение с точкой

Выберите это действие, чтобы соединить последовательность линии с точкой с определенным именем.

Игнорировать соединение

Выберите это действие, чтобы игнорировать любые операции соединения.

Замыкание на точку

Выберите это действие, чтобы замкнуть первую точку в последовательности с таким же кодом объекта. Требуется не менее трех точек. Точки должны иметь один код объекта, а после кода объекта последней точки необходимо указать код управления «Закрыть».

Используется для замыкания объекта, когда он заканчивается или начинается новый объект.

При наличии заданного для используемого общего кода объекта стиля линии замыкание производится линией заданного стиля. Если стиль не задан, используется стиль линии по умолчанию для текущего слоя.

Совет. Сначала задайте для слоев стиль линии по умолчанию.

Запускает касательную дугу

Выберите это действие, чтобы начать касательную дугу. Требуются точки, определяющие вход касательной. Направление входа касательной задается азимутом между точкой с кодом управления начала дуги и предыдущей точкой с таким же кодом объекта.

Дугу можно создать при перечисленных ниже условиях.

  • Дуга начинается и заканчивается по касательной там, где имеются точки, определяющие направления входа и выхода касательной. Это значит, что для полной касательной дуги требуется четыре точки. Если не равны радиусы, вычисленные по двум точкам касания, система автоматически добавляет новую точку и короткий отрезок касательной, чтобы получить две истинные точки касания.
  • Дуга начинается по касательной и заканчивается не по касательной в точке, по которой можно определить направление входа касательной. Система использует известную точку касания и направление касательной наряду с конечной точкой дуги для вычисления центральной точки дуги и добавления дуги.
  • Дуга начинается не по касательной, на дуге фиксируется одна или несколько точек, а затем она заканчивается не по касательной. Система использует зафиксированные на дуге точки для вычисления центральной точки, обеспечивающего оптимальное прохождение дуги через данные точки, а затем добавляет дугу. При использовании трех точек дуга проходит через среднюю точку.

Завершить касательной дугой

Выберите это действие, чтобы завершить касательную дугу. Требуются точки, определяющие выход касательной. Направление выхода касательной задается азимутом между точкой с кодом управления конца дуги и следующей точкой с таким же кодом объекта.

При использовании этих кодов управления центральная точка дуги определяется путем расчета по имеющимся данным.

Начинает некасательную дугу

Выберите это действие, чтобы начать некасательную дугу. Предыдущая точка с таким же кодом объекта не требуется.

Для некасательной дуги требуется три или более точек (точки начала и конца дуги и одна или несколько точек между ними, определяющие дугу). Используемые точки должны иметь одинаковый код объекта.

Примечание. Если между точками «Начало дуги» и «Конец дуги» нет точек с тем же кодом объекта, строится касательная дуга, центральная точка которой является средней точкой между двумя имеющимися точками.

Завершить некасательной дугой

Выберите это действие, чтобы закончить некасательную дугу. Для определения конца дуги таким способом следующая точка с таким же кодом объекта не требуется.

Так заканчивается некасательная дуга, начатая предыдущим управляющим кодом начала дуги. Дуга определяется тремя точками. При использовании этих кодов управления создается кривая, обеспечивающая оптимальное прохождение дуги через данные точки. По кривой определяется центральная точка.

См. также:

Работа с кодами управления линиями

Создание и редактирование кодов управления линиями


Работа с группами определений объектов и кодов управления линиями

Некоторые полевые устройства позволяют группировать набор кодов определений объектов и кодов управления линиями так, чтобы они соответствовали кнопкам на устройстве. Вы можете создать несколько групп, из которых полевые партии будут выбирать нужную группу для конкретной работы.

См. также:

Создание и редактирование групп определений объектов и кодов управления линиями

Опции групп


Создание и редактирование групп определений объектов и кодов управления линиями

Процедура создания группы определений объектов и кодов управления линиями

  1. В панели «Проводник» щелкните файл, в который требуется добавить новую группу.
  2. Выполните одно из приведенных ниже действий.
    • Выберите «Правка > Создать > Создать группу».
    • Щелкните значок [image] на панели инструментов.

    Отобразится окно «Свойства группы», и значок новой группы отобразится в панели «Проводник».

    Примечание. Полные описания всех опций, доступных в панели «Свойства группы» см. в разделе «Опции группы.».

  3. Введите значения в поля «Имя» и «Описание».
  4. Выберите определение объекта или код управления линиями в списке «Все коды».
  5. Нажмите кнопку со стрелкой влево для добавления кода в список «Коды в группе» слева.

    Примечание. Также можно дважды щелкать коды в списке «Все коды» для перемещения их в группу.

    Можно объединить два или более определений объектов и (или) кодов управления линиями, чтобы облегчить назначение объектов в полевых условиях, как описывается на следующем шаге.

  6. Процедура объединения кодов определений объектов и кодов управления линиями.
    1. В списке «Коды в группе» выберите код для объединения.
    2. В списке «Все коды» выберите код для объединения с уже выбранным кодом в списке «Коды в группе».
    3. Щелкните значок [image]. Выбранный второй код будет объединен с кодом в списке «Коды в группе».
    4. Повторяйте шаги a – с для объединения дополнительных кодов.
  7. Повторяйте эту процедуру для добавления дополнительных кодов в группу. Общее число кодов, которые можно добавить, отображается в списке «Коды в группе».

    Примечание. Коды объектов можно добавлять в несколько групп. Вы также можете использовать код объекта в одной группе несколько раз, если он объединен с различными кодами управления.

  8. При необходимости, для изменения последовательности кодов в группе используйте кнопки со стрелкой стрелка вверх и стрелкой вниз.
  9. Завершив операции щелкните другой объект в панели «Проводник» для сохранения изменений.

Процедура редактирования существующей группы

  1. В панели «Проводник» щелкните имея группы, которую требуется изменить. Отобразится панель «Свойства группы».
  2. При необходимости измените имя и (или) описание.
  3. При необходимости внесите изменения в список «Коды в группе», как описано выше.
  4. Завершив операции щелкните другой объект в панели «Проводник» для сохранения изменений.

См. также:

Работа с группами определений объектов и кодов управления линиями

Опции групп


Опции групп

Эти опции используются для создания групп определений объектов и кодов управления линиями, которые будут использоваться в полевом устройстве. Они доступны в панели «Свойства группы».

Опции

Имя

Введите идентификатор для группы.

Описание

Введите дополнительную информацию о группе.

Коды

Коды в группе - отображает все добавленные в группу определения объектов и коды управления линиями, позволяя выбирать, удалять и упорядочивать их.

Все коды - отображает все определения объектов и коды управления линиями в текущем файле, позволяя выбирать любые коды и добавлять их в группу.

Сортировать по алфавиту - установите этот флажок, чтобы на полевом устройстве сортировка списка Кодов в группе производилась в алфавитном порядке.

См. также:

Работа с группами определений объектов и кодов управления линиями

Создание и редактирование групп определений объектов и кодов управления линиями


Экспорт и загрузка данных определений объектов

Данные определений объектов можно загрузить непосредственно в полевое устройство или экспортировать в файл. Производится экспорт всех определений объектов независимо от того, содержат они атрибуты или нет. Но коды управления линиями не экспортируются. Определения объектов экспортируются как объекты-точки.

Процедура загрузки определений объектов в полевое устройство

  1. Убедитесь, что файл, из которого будут экспортироваться данные, или один из его узлов выбран в панели «Проводник».
  2. Подключите полевое устройство к компьютеру.
  3. Выберите «Файл> Экспорт». Отобразится диалоговое окно «Файл экспорта».
  4. Нажмите «Загрузить в устройство».
  5. Выберите полевое устройство в списке «Название устройства».
  6. Выберите программу в списке «Приложение».
  7. Нажмите «OK».

Процедура экспорта данных определений объектов в файл

  1. Убедитесь, что файл, из которого будут экспортироваться данные, или один из его узлов выбран в панели «Проводник».
  2. Выберите «Файл> Экспорт». Отобразится диалоговое окно «Файл экспорта».
  3. Нажмите «Экспорт в файл».
  4. Выберите формат экспортируемого файла в списке «Тип файла».
  5. Выполните одно из приведенных ниже действий.
    • Введите путь к файлу и имя файла в поле «Файл назначения».
    • Щелкните значок [image], чтобы открылось диалоговое окно «Сохранить как». В диалоговом окне «Сохранить» введите имя файла, выберите тип файла и место его хранения. Затем нажмите «OK». Путь к файлу и его имя отобразятся в поле «Файл назначения».
  6. В диалоговом окне «Файл экспорта» нажмите «OK».

См. также:

Опции экспорта и загрузки

Форматы импорта и экспорта

Экспорт файлов словарей данных (.ddf)


Опции экспорта и загрузки

Эти опции используются для отправки данных в другое приложение или на полевое устройство. Они доступны в диалоговом окне «Файл экспорта».

Опции
Исходный файл | Выберите или введите имя и путь к экспортируемому файлу или щелкните значок [image] для перехода к другой папке.
Экспорт в файл | Выберите эту опцию для экспорта исходного файла в другой файл на компьютере или в сети.
Загрузить в устройство | Выберите эту опцию для загрузки файла на полевое устройство.
Тип файла | Выберите формат экспортируемого файла.
Файл назначения | Выберите или введите путь для экспорта файла, либо щелкните значок [image] для перехода к другой папке.
Название устройства | Отображает название подключенного полевого устройства.
Приложение | Выберите полевую программу, для которой предназначен данный файл.

См. также:

Экспорт и загрузка данных определений объектов

Форматы импорта и экспорта

Экспорт файлов словарей данных (.ddf)


Экспорт файлов словарей данных (.ddf)

При использовании программы Trimble® GPS Pathfinder вы можете экспортировать файлы словарей данных (.ddf) в Редактор словаря данных. Экспортирование данных элементов в этом формате избавляет вас от необходимости повторного создания атрибутов в Редакторе словаря данных.

  • В файл словаря данных экспортируются все объекты, независимо от выбранного. Определения объектов экспортируются независимо от того, содержат они атрибуты или нет.
  • Определения объектов экспортируются как объекты-точки. Вы можете изменить тип объекта на линию в Редакторе словаря данных.
  • Файлы словарей данных содержат только имя, код и атрибуты объекта. Не производится экспорт никаких других данных объекта, таких как слои, стили линий, группы и управляющие коды.

См. также:

Экспорт и загрузка данных определений объектов

Опции экспорта и загрузки

Форматы импорта и экспорта


Просмотр отчетов

Для просмотра доступны отчеты различных типов. Для просмотра отчета выберите «Файл > Отчет» и отчет для просмотра. Отчет отображается в отдельном окне браузера.


Previous Topic

Next Topic

Правовая информация


Контактная информация

Trimble Navigation Limited
Engineering and Construction
5475 Kellenburger Road
Dayton, Ohio 45424-1099
U.S.A.

Телефон: +1-937-233-8921
Бесплатный звонок: +1-800-538-7800
Факс: +1-937-233-9441

www.trimble.com

Авторские права и товарные знаки

© Trimble Navigation Limited, 2006 – 2011 гг. Все права защищены.

Логотип «Глобус и треугольник» и Trimble являются товарными знаками Trimble Navigation Limited, зарегистрированными в Бюро патентов и товарных знаков США и в других странах. Digital Fieldbook и Trimble Geomatics Office являются товарными знаками Trimble Navigation Limited. Interlock и Recon являются товарными знаками Tripod Data Systems Inc. – дочерней компании, полностью принадлежащей Trimble Navigation Limited. Microsoft, Windows и ActiveSync являются товарными знаками корпорации Microsoft или товарными знаками, зарегистрированными в США и (или) других странах. Все остальные товарные знаки являются собственностью соответствующих владельцев.

Примечание к выпуску

Это справка для программы Trimble® Feature Definition Manager версии 2.08.