欢迎你使用Feature Definition Manager

欢迎你使用Feature Definition Manager联机帮助，本软件工具便于你创建和管理要素定义（属性），这些要素定义很容易上载到工地设备上，测量员可以给在工地上遇到的对象指定它们。 然后可以用办公室测量数据处理软件处理这些要素和记录的其他测量数据，将它们导出到其他系统上（例如CAD软件包）。

了解Feature Definition Manager

要素是测量员在收集测量数据时可能观测并记录的天然对象或人工对象。 树木、栅栏、闸门、标志、电线杆和建筑物都是要素。 为了简单高效地记录被观测对象的要素信息，测量员可以在自己的工地设备上选择被称为要素定义的预定义要素库，给对象指定合适定义的唯一要素代码。 实际上可以给对象指定与要素定义关联的所有属性（例如要素名称和代码，在图形化软件视图上用于表示对象的符号，以及其他任何定制属性）。

有两种基本要素，每一种用不同的要素定义表示：

  • 一个点要素用于标识树木或电线杆等一个要素。 在浏览屏面上，点要素定义用 [image] 图标表示。
  • 一个直线要素由两个或多个点构成，定义栅栏或道路等直线。 在浏览屏面上，直线要素定义用 [image] 图标表示。 直线要素还可以包括线控制代码，这些代码用于进一步定义线性要素（例如在两点之间添加直线、曲线或弧线）。

相关主题

Feature Definition Manager工作流程

了解界面


Feature Definition Manager工作流程

下列步骤说明使用Feature Definition Manager的高级工作流程。 单击任何一个链接了解详情。

  1. 打开或创建一个要素定义(.fxl)文件，或者下载或导入要素定义数据。
  2. 输入和编辑要素定义(.fxl)文件属性。
  3. 创建和编辑要素定义类别。
  4. 创建和编辑要素定义。
  5. 创建和编辑要素定义所用的符号。
  6. 创建和编辑与直线要素定义一起使用的偏移线。
  7. 添加和编辑要素定义的属性。
  8. 创建和编辑线控制代码。
  9. 创建要素定义代码和线控制代码组。
  10. 保存要素定义(.fxl)文件。
  11. 导出文件或将文件上载到工地设备。

相关主题

欢迎你使用Feature Definition Manager

了解界面


了解界面

Feature Definition Manager界面包括下列常用元素。

用户界面

菜单栏

它便于你快速使用所有命令。 你可以：

  • 单击一个菜单项
  • 按[ALT]键和菜单项上带下划线的字母（助记符）。 然后可以按另一个助记符，或者使用上下箭头键，再按[ENTER]键进行选择。

工具栏

它便于你通过图标快速使用最常用的命令。

工具栏上还有一个搜索字段，可以在此输入要素代码。 按[Enter]键，在浏览屏面上选择要素。

浏览屏面

此屏面用树状视图显示每个文件里的类别、要素、线控制代码和组。 浏览屏面便于你迅速查看、选择、移动和组织文件里的元素。

你可以在浏览屏面上：

  • 打开多个文件。
  • 单击右键，在上下文菜单上选择选项，创建新文件、新类别、新要素和新组。

属性和属性屏面

这些屏面便于你编辑所选文件的属性、类别、要素、组和线控制代码。

图形视图

图形视图告诉你要素符号和注释在图形视图里如何显示，以及如何选择和移动注释。

注意：如要全景显示图形视图，单击并拖动鼠标中键。 如要缩放视图，滚动鼠标轮即可。

状态栏

状态栏显示当前类别和要素名称，以及光标在图形视图中的位置。

相关主题

欢迎你使用Feature Definition Manager

Feature Definition Manager工作流程


获得帮助

本帮助系统包括各种所需信息查找方法。

选项
目录 | 单击此选项卡按树结构显示所有帮助主题。 单击一章或一个主题查看其内容。
搜索 | 在搜索字段输入一个关键字。 然后单击列出主题，搜索该关键字所在的任何帮助主题。 在搜索结果里选择一个主题，单击显示打开它。 在每个帮助主题里突出显示你搜索的关键字。 参看下面的搜索突出显示开/关选项。
隐藏/显示 | 单击此选项隐藏目录和搜索选项卡。
返回 | 单击此按钮查看上一个主题。
打印 | 单击此按钮打开打印主题对话框。 选择一个选项，要么打印所选主题，要么打印标题和所有子主题。
选项菜单
停止 | 单击此按钮结束搜索功能。
刷新 | 单击此按钮刷新当前页显示的内容。
Internet选项 | 单击此选项打开Internet选项对话框，可以在此设置Internet安全、隐私、内容、连接、程序和其他设置。
搜索突出显示开/关 | 单击此选项启用/禁用关键字在搜索主题中的突出显示。

相关主题

欢迎你使用Feature Definition Manager


发送反馈

我们自始至终致力于给你提供最有用的帮助文档。 如果你对帮助、版本说明、速览、教程或工作流程指南有任何改进意见或建议，请随时联系我们：
OSG_Documentation@Trimble.com

你提交的所有意见和建议归Trimble Navigation Limited.所有。


管理要素定义(.fxl)文件

要素定义(.fxl)文件包含下列类型的信息，这些信息按Feature Definition Manager的本机格式组织：

  • 要素定义类别
  • 要素定义
  • 要素属性
  • 线控制代码
  • 要素定义/线控制组
  • 符号和线型

相关主题

创建要素定义(.fxl)文件

打开要素定义(.fxl)文件

将FCL文件转换成FXL文件

输入和编辑要素定义(.fxl)文件属性

要素定义(.fxl)文件属性

创建要素定义(.fxl)文件模板

保存要素定义(.fxl)文件


创建要素定义(.fxl)文件

创建新要素定义(.fxl)文件：

  1. 执行下列操作之一：
    • 选择文件>新建文件。
    • 单击工具栏上的 [image] 图标。

    浏览屏面显示一个名为新建文件的文件夹图标，打开文件属性屏面。

  2. 单击任何一个字段，按需要编辑字段值。

    参看文件属性部分，进一步了解说明。

    注意：最大长度"0"表示不设置极限。

  3. 在完成操作之后，执行下列操作之一：
    • 选择文件>保存。
    • 单击工具栏上的 [image] 图标。

    打开保存对话框。

  4. 在保存对话框上输入文件名称，选择文件类型和文件存储位置。 然后单击确定按钮。

浏览屏面上的新建文件被你指定的路径和文件名取代。

相关主题

管理要素定义(.fxl)文件

打开要素定义(.fxl)文件

将FCL文件转换成FXL文件

输入和编辑要素定义(.fxl)文件属性

要素定义(.fxl)文件属性

创建要素定义(.fxl)文件模板

保存要素定义(.fxl)文件


打开要素定义(.fxl)文件

打开现有的要素定义(.fxl)文件：

  1. 执行下列操作之一：
    • 选择文件>打开。
    • 单击标准工具栏上的 [image] 图标。

    打开打开文件对话框。

  2. 在打开文件对话框上找到要打开的文件，单击确定按钮。

    浏览屏面显示文件图标，打开文件属性屏面。

    注意：
    Feature Definition Manager提供的样本数据FXL软件安装在Program Files文件夹下面的application子文件夹里， 但在打开本软件时，在(My) Documents文件夹下面的子文件夹里创建第二个版本，可以通过文件菜单打开它。 建议你使用此版本的文件，而不使用Program Files文件夹下面的application子文件夹保存的原始版本。
    — 所有要素定义(.fxl)文件默认按Feature Definition Manager最新版格式打开和保存，此格式兼容Trimble Access和Survey Controller v12.40和更高版本。

相关主题

管理要素定义(.fxl)文件

创建要素定义(.fxl)文件

将FCL文件转换成FXL文件

输入和编辑要素定义(.fxl)文件属性

要素定义(.fxl)文件属性

创建要素定义(.fxl)文件模板

保存要素定义(.fxl)文件


将FCL文件转换成FXL文件

将FCL文件转换成FXL文件：

  1. 选择文件>转换文件。 打开转换文件对话框。
  2. 在选择源文件字段输入要转换的.fcl文件的文件名和路径，或者单击 [image] 按钮找到.fcl文件。
  3. 在定义目标字段输入目标.fxl文件的文件名和路径，或者单击 [image] 按钮找到.fxl文件。
  4. 在选择语言列表上选择.fcl文件使用的语言。
  5. 选择要将.fcl文件转换成哪个版本的.fxl文件。
  6. 单击确定按钮。

    浏览屏面显示新创建的.fxl文件对应的文件图标。


输入和编辑要素定义(.fxl)文件属性

输入或编辑要素定义(.fxl)文件属性：

  1. 在浏览屏面上选择要处理的文件。
  2. 执行下列操作之一：
    • 选择文件>属性。
    • 单击工具栏上的 [image] 图标。

    打开文件属性屏面。

  3. 单击任何一个字段，按需要编辑值。

    参看文件属性部分，进一步了解说明。

    注意：最大长度"0"表示不设置极限。

  4. 在完成操作之后，执行下列操作之一：
    • 选择文件>保存。
    • 单击工具栏上的 [image] 图标。

    如首次设置新文件的属性，打开保存对话框。 在保存对话框上输入文件名称，选择文件类型和文件存储位置。 然后单击确定按钮。

相关主题

管理要素定义(.fxl)文件

创建要素定义(.fxl)文件

打开要素定义(.fxl)文件

将FCL文件转换成FXL文件

要素定义(.fxl)文件属性

创建要素定义(.fxl)文件模板

保存要素定义(.fxl)文件


要素定义(.fxl)文件属性

用这些选项指定创建者、说明、要素代码是否只能是数字以及某些字段的最大长度。 可在文件属性屏面上使用它们。

选项
创建者 | 输入文件创建者的姓名。
说明 | 输入有关文件的附加信息。
创建日期 | 显示首次保存文件时的只读日期。
修改日期 | 显示上次保存文件时的只读日期。
指定要素代码是否只能用数字。 | 否 — 选择此选项，表示允许使用字母数字代码。 是 — 选择此选项，表示只能使用数字代码。
最大属性名称长度 | 输入任何属性名称字段允许的最大字符数值。 注意：最大长度"0"表示不设置极限。
最大类别名称长度 | 输入任何类别名称字段允许的最大字符数值。
最大要素名称长度 | 输入任何要素名称字段允许的最大字符数值。
最大要素代码长度 | 输入任何要素代码字段允许的最大字符数值。
最大代码/组数 | 输入任何组允许的最大要素或控制代码数值。 这取决于你要使用的工地设备的型号。

相关主题

管理要素定义(.fxl)文件

创建要素定义(.fxl)文件

打开要素定义(.fxl)文件

将FCL文件转换成FXL文件

输入和编辑要素定义(.fxl)文件属性

创建要素定义(.fxl)文件模板

保存要素定义(.fxl)文件


创建要素定义(.fxl)文件模板

可以创建一个或多个包含最常用要素数据的模板。 这样可以节省时间，确保工程之间的一致性。

创建模板文件：

  1. 打开一个与要创建的模板类似的现有文件，或者创建一个新文件。

    注意：对于下列步骤，参看适当的帮助主题了解说明。

  2. 按需要设置文件属性。
  3. 按需要创建、编辑和删除类别、要素、属性、控制代码和组。
  4. 按需要创建、编辑和删除注释和符号。
  5. 选择文件>另存为。 打开另存为对话框。
  6. 在另存为对话框上执行下列操作：
    1. 输入文件的名称。
    2. 选择文件类型。
    3. 选择文件存储位置。
    4. 单击确定按钮。

相关主题

管理要素定义(.fxl)文件

创建要素定义(.fxl)文件

打开要素定义(.fxl)文件

将FCL文件转换成FXL文件

输入和编辑要素定义(.fxl)文件属性

要素定义(.fxl)文件属性

保存要素定义(.fxl)文件


保存要素定义(.fxl)文件

要经常尽早保存要素定义(.fxl)文件。

警告：在保存文件之前，不保存对文件所做的更改。

保存要素定义(.fxl)文件：

  1. 执行下列操作之一：
    • 选择文件>保存。
    • 单击工具栏上的 [image] 图标。

    如在此之前保存了文件，不显示对话框，保存文件。 如这是首次保存文件，打开保存对话框。

  2. 如打开保存对话框，执行下列操作：
    1. 输入文件的名称。
    2. 选择文件类型。
    3. 选择文件存储位置。
    4. 单击确定按钮。 浏览屏面上的新文件被你指定的路径和文件名取代。

用新名称保存要素定义(.fxl)文件：

  1. 选择文件>另存为。 打开另存为对话框。
  2. 在另存为对话框上执行下列操作：
    1. 输入文件的名称。
    2. 选择文件类型。
    3. 选择文件存储位置。
    4. 单击确定按钮。 浏览屏面显示新文件名。

相关主题

管理要素定义(.fxl)文件

创建要素定义(.fxl)文件

打开要素定义(.fxl)文件

将FCL文件转换成FXL文件

输入和编辑要素定义(.fxl)文件属性

要素定义(.fxl)文件属性

创建要素定义(.fxl)文件模板


下载和导入要素定义数据

可以直接下载工地设备上的要素定义数据，也可以导入保存在文件里的要素定义数据。

注意：为了导入或下载数据，必须打开一个文件。 导入和下载的数据保存在当前文件里。

下载工地设备上的要素定义数据：

  1. 将工地设备连接到计算机。
  2. 单击文件>导入。 打开导入文件对话框。
  3. 单击从设备下载。
  4. 在设备名称列表上选择一种工地设备。
  5. 在应用程序列表上选择一个程序。
  6. 单击确定按钮。 浏览屏面显示下载数据所在的文件。

导入文件里的要素定义数据：

  1. 单击文件>导入。 打开导入文件对话框。
  2. 单击从文件导入。
  3. 在源文件字段输入文件路径和名称，或者单击 [image] 按钮找到所需的文件。
  4. 在应用程序列表上选择一个程序。
  5. 单击确定按钮。 浏览屏面显示导入数据所在的文件。

相关主题

下载和导入选项

导入和导出格式

导入数据字典文件(.ddf)


下载和导入选项

用这些选项导入另一个应用程序或工地设备上的外部数据。 可在导入文件对话框上使用它们。

Feature Definition Manager的本机文件格式是.fxl，可以有效存储和管理要素定义。 该管理器的导入器还兼容其他许多格式。

选项
源文件 | 指定要导入的路径和文件，或者单击 [image] 按钮找到该文件。
文件类型 | 此字段显示所选文件的格式。
从文件导入 | 单击并选择本地硬盘或网络硬盘存储的文件。
从设备下载 | 单击并选择所连接的工地设备存储的文件。
设备名称 | 此字段显示你连接的工地设备的名称。
应用程序 | 选择要处理要素文件的外业软件。

相关主题

下载和导入要素定义数据

导入和导出格式

导入数据字典文件(.ddf)


导入和导出格式

Feature Definition Manager便于你采用下列格式从多种软件程序里导入数据，以及将这些格式的数据导出到这些软件程序里。

导入 | 文件格式 | 导出
 | .fal — 要素和属性库文件 |
 | .ddf — 数据词典文件 |
 | .csv — 文本文件 |
 | .lst — Nikon代码表文件 |
 | .xml — Geodatabase文件 |

相关主题

下载和导入要素定义数据

导入数据字典文件(.ddf)

下载和导入选项


导入数据字典文件(.ddf)

如使用Trimble GPS Pathfinder软件，可以从数据词典编辑器导入数据词典文件(.ddf)。 如用此格式导入要素数据，就不必在Feature Definition Manager里重新创建属性。

在导入数据词典文件时，所有直线要素和面积要素均被转换成点要素，但属性定义保持不变。

如要素定义库里已经有一个同名的.ddf要素：

  • .ddf版本的属性覆盖现有要素的属性。
  • 现有要素的点式样模板、线型模板和注释模板保持不变，因为.ddf文件不包含此类信息。

如要素库里没有.ddf要素，由于没有定义点式样，该要素将显示一个问号。

否则，从数据词典文件导入的要素与在Feature Definition Manager里创建的要素基本相同。

相关主题

下载和导入要素定义数据

下载和导入选项

导入和导出格式


导入Geodatabase文件(.xml)

在导入Geodatabase (.xml)文件里的要素定义时，注意下列事项：

  • Geodatabase文件不支持要素定义代码。 在把Geodatabase文件导入Feature Definition Manager时，把定义名称用作定义代码。 可以在导入之后更改名称或代码。
  • Geodatabase文件不允许要素定义名称有空格。 在把Geodatabase文件导入Feature Definition Manager时，定义名称和定义代码使用下划线，而不使用空格。 可以在导入之后编辑名称或代码。
  • Geodatabase文件不支持类别。 在把Geodatabase文件导入Feature Definition Manager时，给导入的所有要素定义指定其他类别。 在导入之后，必要时可以把要素定义归入新类别或现有类别。
  • Geodatabase文件不支持默认属性值或直线和符号。 在导入之后，必要时可以添加这些属性。

相关主题

下载和导入要素定义数据

下载和导入选项

导入和导出格式


处理要素定义类别

可以用类别将要素定义分成几组相似的定义。 类别有助工地作业团队在准备收集工地数据时，快速选择特定类型的作业所需的要素定义。

在浏览屏面上选择一个类别之后，主窗口显示该类别的要素定义的列表。

相关主题

创建和编辑要素定义类别


创建和编辑要素定义类别

创建要素定义类别：

  1. 在浏览屏面上用右键单击要添加新类别的文件，选择新建>新建类别。 打开新类别名称屏面。
  2. 在名称字段输入新类别名称。
  3. 单击浏览屏面上的任何地方。 浏览屏面显示新类别。

编辑要素定义类别名称：

  1. 在浏览屏面上单击要编辑的类别的名称。 打开类别名称屏面。
  2. 在名称字段输入新类别名称。
  3. 单击浏览屏面上的任何地方。 浏览屏面显示新命名的类别。

相关主题

处理要素定义类别


处理要素定义

要素定义用于表示工地上可能有的要素的类型（例如人行道和电线杆等）。 Feature Definition Manager有一组预定义要素定义，你可以在创建自己的要素定义库时把它们用作起点。

虽然可以同时打开多个有相同要素定义名称和/或代码的文件，但一个文件里的每个要素定义必须有一个唯一名称和代码。

工具栏上还有一个搜索字段，可以在此输入要素定义名称、控制代码名称或组名称。 按[Enter]键，在浏览屏面上选择名称。

有两种可用要素定义：

  • 一个点要素用于标识树木或电线杆等一个要素。 在浏览屏面上，点要素定义用 [image] 图标表示。
  • 一个直线要素由两个或多个点构成，定义栅栏或道路等直线。 在浏览屏面上，直线要素定义用 [image] 图标表示。 直线要素还可以包括线控制代码，这些代码用于进一步定义线性要素（例如在两点之间添加直线、曲线或弧线）。

相关主题

创建和编辑要素定义

要素定义选项


创建和编辑要素定义

创建要素定义：

  1. 单击浏览面板上要添加新要素的文件。
  2. 执行下列操作之一：
    • 选择编辑>新建>新建要素定义。
    • 单击新建工具栏上的 [image] 图标。

    打开新建要素定义对话框。

    注意：如要了解下列步骤，参看要素定义选项了解详情。

  3. 在名称字段和代码字段里输入合适的值。
  4. 在类别列表、类型列表、颜色列表和图层列表上选择合适的选项。
  5. 必要时选择包括在表面、表面断开线或反向选项。 （只有在创建直线要素定义时，才能使用表面断开线和反向选项。）
  6. 在完成操作之后，单击确定按钮。 在浏览面板上所选类别下面添加一个新要素定义图标。

编辑现有要素定义：

  1. 单击浏览面板上要编辑的要素定义的名称。 打开要素定义属性面板。
  2. 单击要素定义属性面板上的任何一个字段，编辑相应的属性。 参看要素定义选项了解详情。
  3. 按TAB键，或者在浏览面板上选择另一项，即可接受更改。

相关主题

使用要素定义

要素定义选项


要素定义选项

用这些选项定义要素定义属性。 可在新建要素定义对话框和要素定义属性面板上使用它们。

选项

名称

输入要素定义唯一标识符。 在每个文件里，任何两个要素定义不能使用相同的名称。

代码

输入要素定义名称唯一缩写。

类别

选择要素定义存储类别。

类型

点要素 — 选择此选项创建点要素定义。 一个点要素用于标识树木或电线杆等一个要素。

直线要素 — 选择此选项创建直线要素定义。 一个直线要素由两个或多个点定义的直线构成，定义栅栏或道路。

图层

如此前给文件定义了图层，给要素定义选择合适的图层。 或者选择下列选项之一：

0 — 选择此选项，让新要素位于默认图层。

点 — 选择此选项，将点要素与其他点要素定义放在同一图层。

新建图层 — 选择此选项打开新建图层对话框，可以在此给新图层定义下列属性。

  • 图层名称
  • 颜色
  • 线型

    如果要导入线型，选择导入线型选项。 打开线型管理器对话框。 可以利用此对话框导入和删除线型。 参看使用线型了解使用说明。

颜色

按图层 — 选择此选项，让要素继承它所在图层的显示颜色。

（颜色）— 给要素定义选择在图形视图上显示时所用的特定颜色。

线型

选择合适的线型。

如果要导入线型，选择导入线型选项。 打开线型管理器对话框。 也可以利用此对话框删除线型。 参看使用线型了解使用说明。

只有在创建或编辑直线要素定义时，才能使用此选项。

线型比例

输入直线符号比例因子。

只有在创建或编辑直线要素定义时，才能使用此选项。

包括在表面

选择此选项，在用另一个应用程序处理要素代码之后，允许在创建表面时使用此要素。

相关主题

使用要素定义

创建和编辑要素定义

使用线型


处理线型

在创建或编辑直线时，如果选择导入线型选项，打开线型管理器对话框。

导入线型：

  1. 选择合适的长度单位和单位引用选项。
  2. 单击浏览按钮找到要从中导入线型的线型文件。
  3. 在右边列表上选择要导入的线型，单击移动(<)按钮将所选线型移到左边列表上，或者单击移动(<<)按钮将右边列表上的所有线型移到左边列表上。 左边列表显示工程里的所有可用线型。
  4. 在完成操作之后，单击确定按钮。 现在可以在线型列表上选择新导入的线型了。

删除线型：

  1. 在左边列表上选择要删除的线型。
  2. 单击删除(X)按钮。
  3. 在完成操作之后，单击确定按钮。

相关主题

要素定义选项

偏移要素线选项


处理要素符号

在办公室测量数据处理软件里，要素可以在图形视图里作为符号显示。 可以指定与每个要素定义一起使用哪些符号。

相关主题

指定、编辑和删除要素符号

要素符号选项


指定、编辑和删除要素符号

给要素定义指定符号：

  1. 在浏览屏面上用右键单击要指定符号的要素定义，选择新建>新建符号。 打开符号对话框。
  2. 如要素符号选项部分所述，填写这些字段。
  3. 在完成操作之后，单击确定按钮。 直线和符号列表显示新指定的符号。

编辑符号：

  1. 在浏览屏面上单击要编辑符号的要素定义。
  2. 在直线和符号列表上双击要编辑的符号。 打开符号对话框。
  3. 如要素符号选项部分所述，填写这些字段。
  4. 在完成操作之后，单击确定按钮。

删除符号：

  1. 在浏览屏面上单击要删除符号的要素定义。
  2. 在直线和符号列表上双击要删除的符号。
  3. 在上下文菜单上选择删除。

相关主题

处理要素符号

要素符号选项


要素符号选项

用符号对话框显示的这些选项定义符号的属性。

选项

名称

输入符号标识符。

说明

输入有关符号的备注。

符号

选择一个表示该要素的符号。

如果要导入符号，选择导入符号选项。 打开符号管理器对话框。 可以利用此对话框导入和删除符号。 参看处理符号了解使用说明。

颜色

按图层 — 选择此选项，在测量数据后处理软件里使用要素代码所在图层的颜色。

按块/要素 — 选择此选项，使用要素所在图层的颜色。

（颜色）— 选择合适的颜色。

布局

旋转

固定值 — 选择此选项打开值字段，可以在此字段输入符号旋转角度。 旋转方向为反时针方向。

属性 — 选择此选项打开属性名称列表，可以在此列表上选择合适的属性名称。 符号按在属性字段里定义的值（度数）旋转。

符号大小和比例

尺寸

地面 — 选择此选项，根据固定值或属性把符号设置为特定的地面尺寸。

纸张 — 选择此选项，根据固定值或属性把符号设置为给工程定义的打印比例。

输入方法

固定值 — 选择此选项打开值字段，可以在此字段里输入符号大小。

如果在尺寸组里选择地面，根据输入值把符号设置为地面尺寸。 例如假如输入1米，符号地面尺寸为1米。

如果在尺寸组里选择纸张，根据输入值把符号设置为给工程定义的打印比例。 例如假如输入1毫米，工程打印比例是100，符号地面尺寸为0.1米(1mm x 100)。 Feature Definition Manager显示符号所用的默认打印比例是100，但工程打印比例可能有所不同。

属性 — 选择此选项打开属性名称列表，可以在此列表上选择合适的属性名称。 符号按指定的属性值进行缩放。

如果在尺寸组里选择地面，根据给所选属性指定的值把符号设置为地面尺寸。例如假如选择值为1的属性，而显示单位是米，符号地面尺寸为1米。

如果在尺寸组里选择纸张，根据给所选属性指定的值把符号设置为给工程定义的打印比例。 例如假如选择值为1的属性，而工程打印比例是100，符号尺寸为0.1米(1mm x 100)。 Feature Definition Manager显示符号所用的默认打印比例是100，但工程打印比例可能有所不同。

注意：如要更改显示单位，单击编辑首选项按钮。 在此选择的显示单位应该与工程使用的显示单位相同。

相关主题

处理要素符号

指定、编辑和删除要素符号

处理符号


使用符号

在使用符号时，如果选择<<导入符号>>选项，打开符号管理器对话框。

导入或删除符号：

  1. 单击符号管理器对话框上的 [image] 按钮，找到要导入的符号所在的文件。

    符号文件默认安装位置是：
    C:\Program Files\Trimble\Feature Definition Manager\PEditor\Symbols.sym
  1. 执行下列操作之一：
    • 如要导入所选文件里的所有符号，单击<<按钮。
    • 如要导入所选文件里的一个符号，在右边的列表上选择此符号，单击<按钮。
    • 如要删除一个符号，在左边的列表上选择此符号，单击X按钮。
  2. 在完成操作之后，单击确定按钮。

相关主题

要素符号选项


处理偏移要素线

如果要给一个直线要素创建一条或多条相对于一条中线的偏移线，可以给用于定义该直线的要素定义指定偏移线。 例如可能要给人行道直线要素添加两条偏移线：一条位于人行道中线左边2单位处，用于定义左边沿，而另一条位于人行道中线右边2单位处，用于定义右边沿。 在此例子里，可以给该要素定义添加两条偏移线：一条使用水平偏移值2，另一条使用水平偏移值-2。 如你愿意，甚至可以用不同的颜色和式样显示偏移线。

注意：在给直线要素定义添加偏移线时，不再显示中线。

相关主题

指定、编辑和删除偏移要素线

偏移要素线选项


指定、编辑和删除偏移要素线

给直线要素定义指定偏移线：

  1. 在浏览屏面上用右键单击要指定偏移线的直线要素定义，选择新建>新建直线。 打开直线对话框。
  2. 如偏移要素线选项部分所述，填写这些字段。
  3. 在完成操作之后，单击确定按钮。 直线和符号列表显示新指定的偏移线。

编辑偏移线：

  1. 在浏览屏面上单击要编辑便移线的要素定义。
  2. 在直线和符号列表上双击要编辑的偏移线。 打开直线对话框。
  3. 如偏移要素线选项部分所述，填写这些字段。
  4. 在完成操作之后，单击确定按钮。

删除偏移线：

  1. 在浏览屏面上单击要删除便移线的要素定义。
  2. 在直线和符号列表上双击要删除的偏移线。
  3. 在上下文菜单上选择删除。

相关主题

处理偏移要素线

偏移要素线选项


偏移要素线选项

用直线对话框显示的这些选项定义偏移要素线的属性。

选项
名称 | 输入偏移线标识符。
说明 | 输入有关偏移线的备注。
线型 | 选择合适的线型。 如果要导入线型，选择导入线型选项。 打开线型管理器对话框。 可以利用此对话框导入和删除线型。 参看处理线型了解使用说明。
比例 | 输入直线符号比例因子。
颜色 | 按图层 — 选择此选项，在测量数据后处理软件里使用要素代码所在图层的颜色。 按块/要素 — 选择此选项，使用要素所在图层的颜色。 （颜色）— 选择合适的颜色。
水平偏移 | 输入在水平方向上偏离要素中心线的距离。 这将画一条附加直线。
垂直偏移 | 输入在垂直方向上偏离要素中心线的距离。 这将画一条附加直线。
偏移类型 | 地面 — 选择此选项，将实际工程单位用于水平偏移距离和垂直偏移距离。 纸张 — 选择此选项，将纸张单位用于水平偏移距离和垂直偏移距离。

相关主题

处理偏移要素线

指定、编辑和删除偏移要素线

处理线型


处理要素属性

要素属性是给要素定义指定的特征，用于进一步描述这些要素。 要素属性可用于：

  • 预定义常见特征，以便工地作业团队迅速将它们应用于要素。 例如对于树要素，可以添加树种、高度、周长和状况等属性。 在工地上收集的每个树要素都有自己的属性值。
  • 控制在工地上可以并必须收集要素的哪些类型的信息。 例如假如你需要记录的每棵树有一个符号，可以给树要素添加符号属性，使其成为必要属性。 工地收集设备将提示并要求工地作业团队给记录的每个属性指定一个符号。

相关主题

指定和编辑要素属性

要素属性选项


指定和编辑要素属性

给要素定义指定属性：

  1. 在浏览屏面上用右键单击要指定属性的要素定义，选择新建>新建属性>（属性类型）。 打开所选属性对应的对话框。

    参看要素属性选项，了解每个可用属性类型的说明和主题链接，了解如何在指定的（属性类型）对话框上输入每个类型的属性。

  2. 在（属性类型）对话框上指定属性之后，单击确定按钮。 主窗口上要素定义部分的属性列表显示新指定的属性。

编辑现有属性：

  1. 在浏览屏面上单击要编辑属性的要素定义。
  2. 在属性列表上双击要编辑的属性。 打开（属性类型）对话框。
  3. 如要素属性选项部分所述，填写这些字段。
  4. 在完成操作之后，单击确定按钮。

相关主题

处理要素属性

要素属性选项


要素属性选项

下列选项允许你添加属性，以便工地作业团队在工地上记录要素时选择它们。 用右键单击一个要素，选择新建 >新建属性，即可打开上下文菜单使用它们。

选项
数字 | 如必须捕捉有数值的属性，例如树木的周长或高度，或特定位置的污染物浓度，选择此选项。 在数字属性字段只能输入整数或小数。
文本 | 如必须捕捉采用字母数字字符的属性，例如街道或公共设施所有者名称，选择此选项。 虽然可以在文本属性里添加数字，但如属性始终是数字，请使用数字属性。
日期 | 如必须捕捉标准日期格式的属性，例如电线杆安装日期，选择此选项。
时间 | 如必须捕捉时间格式的属性，例如记录要素的小时和分钟，选择此选项。
列表 | 如必须在列表上的多个选项中选择选项来捕捉属性，例如工程里的五个可能的标志，选择此选项。
文件 | 如必须捕捉文件属性，选择此选项。
照片 | 如必须捕捉照片属性，选择此选项。

相关主题

处理要素属性

指定和编辑要素属性


要素属性：数选项

用这些选项定义由数值构成的属性。 可在数对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。
默认值 | 输入即将输入的最常用的值；它自动出现在属性字段里。
工地设备特定的 |
最小值 | 输入属性允许的最小数。
最大值 | 输入属性允许的最大数。
小数位数 | 输入小数点后面的小数位数。 输入0值表示只允许输入整数。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：整数选项

用这些选项定义由整数值构成的属性。 可在整数对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。
默认值 | 输入即将输入的最常用的值；它自动出现在属性字段里。
工地设备特定的 |
最小值 | 输入属性允许的最小整数。
最大值 | 输入属性允许的最大整数。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：文本选项

用这些选项定义由字母、数字和要输入的其他字符字符串构成的文本属性。 可在文本对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须输入要素文件定义里。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。
默认值 | 输入即将输入的最常用的值；它自动出现在属性字段里。 如不输入默认值，此属性的值初次设置为空（无值）。
最大长度 | 输入可输入的最大字符长度（最多100个字符）。 必须指定此字段的值；默认值是30。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：日期选项

用这些选项定义日期属性的格式。 可在日期对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如在该字段里不设置属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须在该字段输入属性，选择此选项。
格式 | 在列表上选择一种日期格式。 注意：如要按其中一种可用的GIS导出格式导出数据，确保你给任何日期属性指定的日期格式与安装了GIS软件的计算机的日期格式相同。 许多GIS系统在导入文件时检查计算机的日期设置，假设文件里的日期格式与计算机的日期设置相同。 如两个日期设置不相同，在GIS软件里可能会出现空值现象。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：时间选项

用这些选项定义时间属性格式。 可在时间对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。
格式 | 在列表上选择一种时间格式。 注意：如要按其中一种可用的GIS导出格式导出数据，确保你给任何日期属性指定的日期格式与安装了GIS软件的计算机的日期格式相同。 许多GIS系统在导入文件时检查计算机的日期设置，假设文件里的日期格式与计算机的日期设置相同。 如两个日期设置不相同，在GIS软件里可能会出现空值现象。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：列表选项

用这些选项定义那些要求许多预定义、可选择值的属性。 可在列表对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。
列表值 | 用这些按钮创建一个可从中选择选项的列表。 向上 — 单击此按钮，将列表上所选的列表项向上移。 向下 — 单击此按钮，将列表上所选的列表项向下移。 默认 — 如不选择其他选项，单击此按钮使所选项成为列表显示的值。 添加 — 单击此按钮，在列表上插入一个新项。 然后输入该项。 删除 — 单击此按钮，从列表上删除一项。 注意：如要编辑一个列表项，在列表值字段里选择它，输入新名称。
默认值 | 输入即将输入的最常用的值；它自动出现在属性字段里。 如不输入默认值，此属性的值初次设置为空（无值）。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：文件选项

用这些选项定义文件属性。 可在文件对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


要素属性：照片选项

用这些选项定义照片属性。 可在照片对话框上使用它们。

选项
名称 | 输入属性标识符。
说明 | 输入有关属性的备注。 此字段是任选的，在工地上工作期间不使用它。
输入模式 | 仅供办公室使用 — 如不能在工地设备上指定属性，选择此选项；它必须通过计算机输入。 任选 — 如用户可以选择是否指定属性，选择此选项。 必填 — 如必须给属性指定一个有效值，选择此选项。 自动生成 — 如属性必须是通过设备捕捉的照片，选择此选项。 自动生成 — 只读 — 如属性必须是通过设备捕捉的照片，不能在设备上编辑照片，选择此选项。

相关主题

处理要素属性

指定和编辑要素属性

要素属性选项


处理线控制代码

测量员可以在工地上收集数据期间给点指定线控制代码，从而指定相关直线要素的属性。 例如他们可以给一个点指定一个线控制代码，从而指定要素线在何处开始或结束。 在用办公室测量数据处理软件处理要素代码时，线控制代码根据代码说明修改直线对象。

注意：可以编辑预定义的可用控制代码列表，但不能更改每个控制代码执行的操作。

相关主题

创建和编辑线控制代码

线控制代码选项


创建和编辑线控制代码

创建新线控制代码：

  1. 执行下列操作之一：
    • 选择编辑>新建>新建线控制代码。
    • 用右键单击浏览屏面，选择新建>新建线控制代码。
    • 单击工具栏上的 i_new control code 图标。

    打开线控制代码对话框。

    注意：参看线控制代码选项，了解线控制代码对话框上所有可用选项的完整说明。

  2. 在名称字段输入代码标识符。
  3. 在代码字段输入代码缩写。
  4. 在所有操作列表上选择要执行的代码操作。 它上面的选择的操作字段显示的信息说明代码如何修改要素。
  5. 单击确定按钮。

编辑现有的线控制代码：

  1. 在浏览屏面上选择要编辑的代码。 主窗口显示线控制代码属性。
  2. 单击名称或代码字段，按需要编辑它们。

    注意：不能更改现有线控制代码要执行的操作。

  3. 按TAB键，或者在浏览屏面上选择另一项，即可接受更改。

相关主题

处理线控制代码

线控制代码选项


线控制代码选项

用这些选项修改控制代码，创建新控制代码。 可在新建线控制代码对话框上使用它们。

选项

名称

输入控制代码标识符。

代码

输入在工地上使用的线控制代码的缩写。

选择的操作

此选项显示的信息说明所选控制代码如何修改要素。

所有操作

起始直线

选择此操作，开始新直线连接序列。 有相同代码的上一个连接序列到此结束。

用此选项防止该点被连接到上一个有相同代码的点，开始新连接序列。

在某些应用里，如果自动连接有相同名称的直线要素，开始新直线并不需要此控制代码。

注意：可以用起始直线生成类似结束直线的结果。

结束直线

选择此操作，结束直线连接序列。

如要防止在有结束直线控制代码的点和下一个有相同要素代码的点之间画一条线，选择此选项。

连接点

选择此操作，将一个直线序列连接到一个指定的点ID。

忽略连接

选择此操作，忽略任何连接操作。

闭合点

选择此操作，与序列里有相同要素代码的第一个点闭合。 至少需要三个点。 这些点必须有相同的要素代码，最后一个点的要素代码还必须后跟闭合线控制代码。

在一个新要素开始或结束时，用此选项使该要素闭合。

如果给所用的通用要素代码定义了线型，用定义的线型画闭合线。 如果没有定义线型，用当前图层的默认线型画闭合线。

提示：先给图层设置默认线型。

起始相切弧线

选择此操作，开始画相切弧线。 需要几个定义入切线的点。 有起始弧线控制代码的点和上一个有相同要素代码的点之间的方位角，定义入切线方向。

在下列情况下可以创建弧线：

  • 弧线起点和终点形成切线，此处的点可用于定义入切线方向和出切线方向。 这意味着全切弧线需要四个点。 如果根据两个切点计算的半径不完全相等，系统将自动增加一个新点和一条短切线，实现两个真正的切点。
  • 起点与一个点相切但终点不相切的弧线，可用于定义入切方向。 系统使用已知的切点、切线方向和弧线终点计算弧线中点，并添加弧线。
  • 弧线起点不相切，弧线上有一个或多个固定点，终点也不相切。 系统使用弧线上的固定点计算通过这些点的最佳弧线的中点，然后添加弧线。 在使用三个点的情况下，弧线通过中点。

结束相切弧线

选择此操作，结束相切弧线。 需要几个定义出切线的点。 有结束弧线控制代码的点和下一个有相同要素代码的点之间的方位角，定义出切线方向。

在使用这些控制代码时，弧线中点用可用数据计算确定。

起始非相切弧线

选择此操作，开始画非相切弧线。 不要求上一个点有相同要素代码。

一条非相切弧线需要三个或多个点（新弧线点、弧线终点、它们之间一个或多个定义该弧线的点）。 使用的点必须有相同的要素代码。

注意：如果新弧线点和弧线终点之间没有有相同要素代码的点，弧线画成相切弧线，弧线中点即为这两个点之间连线的中点。

结束非相切弧线

选择此操作，结束非相切弧线。 用此方法结束弧线不要求下一个点有相同要素代码。

这将结束以上一个新弧线控制代码开始的非相切弧线。 一条弧线用三个点定义。 在使用这些控制代码时，在这些点之间画一条最佳曲线。 根据此曲线确定中点。

相关主题

处理线控制代码

创建和编辑线控制代码


处理要素定义/线控制组

某些工地设备允许你将一组要素定义代码和线控制代码组合在一起，使它们与设备上的按钮相对应。 可以创建多个组，便于工地作业团队从中选择一个适合特定作业要求的组。

相关主题

创建和编辑要素定义/线控制组

组选项


创建和编辑要素定义/线控制组

创建一组要素定义和线控制代码：

  1. 在浏览屏面上单击要添加新组的文件。
  2. 执行下列操作之一：
    • 选择编辑>新建>新建组。
    • 单击工具栏上的 [image] 图标。

    打开组属性屏面，浏览屏面显示新组图标。

    注意：参看组选项，了解组属性屏面上所有可用选项的完整说明。

  3. 在名称和说明字段输入值。
  4. 在所有代码列表上选择一个要素定义或线控制代码。
  5. 单击左箭头按钮，将代码左移到组代码里。

    注意：也可以双击所有代码列表上的代码，将它们移到该组里。

    可以如下一步所述，将两个或多个要素定义和/或线控制代码合并在一起，在工地上更容易指定要素。

  6. 合并要素定义代码和/或线控制代码：
    1. 在组代码列表上选择一个要合并的代码。
    2. 在所有代码列表上选择一个要与在组代码列表上选择的代码合并在一起的代码。
    3. 单击 [image] 图标。 所选的第二个代码与组代码列表上的代码合并在一起。
    4. 必要时重复步骤a-c合并其他代码。
  7. 必要时重复此过程，将其他代码添加到组里。 组代码列表上面显示可以包括的代码总数。

    注意：要素代码可以放在多个组里。 只要一个要素代码与一个不同的控制代码组合在一起，你还可以在一个组里多次使用一个要素代码。

  8. 如有必要，单击向上和向下箭头图标排列组里的代码。
  9. 在完成操作之后，单击浏览屏面上的另一个对象即可保存更改。

编辑现有组：

  1. 在浏览屏面上单击要编辑的组的名称。 打开组属性屏面。
  2. 如有必要，更改名称和/或说明。
  3. 如有必要，如上所述更改组代码列表。
  4. 在完成操作之后，单击浏览屏面上的另一个对象即可保存更改。

相关主题

处理要素定义/线控制组

组选项


组选项

用这些选项新建一组在工地设备上使用的要素定义和线控制代码。 可在组属性屏面上使用它们。

选项
名称 | 输入组标识符。
说明 | 输入有关组的附加信息。
代码 | 组代码 — 显示你到此为止给该组添加的每个要素定义和线控制代码，便于你选择、删除或重新排列任何代码。 所有代码 — 显示当前文件里的所有要素定义和线控制代码，便于你选择任何代码并把它添加到该组里。 按字母顺序排序 — 选择此选项排序组代码列表，使它们在工地设备上按字母顺序列出来。

相关主题

处理要素定义/线控制组

创建和编辑要素定义/线控制组


导出和上载要素定义数据

可以将要素定义数据直接上载到工地设备上，也可以将要素定义数据导出到文件里。 导出所有要素定义，无论它们是否包含属性，但不导出线控制代码。 要素定义作为点要素导出。

将要素定义数据上载到工地设备上：

  1. 确保在浏览屏面上选择导出数据所在的文件或其中一个嵌套节点。
  2. 将工地设备连接到计算机。
  3. 单击文件>导出。 打开导出文件对话框。
  4. 单击上载到设备。
  5. 在设备名称列表上选择一种工地设备。
  6. 在应用程序列表上选择一个程序。
  7. 单击确定按钮。

将要素定义数据导出到文件里：

  1. 确保在浏览屏面上选择导出数据所在的文件或其中一个嵌套节点。
  2. 单击文件>导出。 打开导出文件对话框。
  3. 单击导出到文件。
  4. 在文件类型列表上选择导出文件的格式。
  5. 执行下列操作之一：
    • 在目标文件字段输入文件路径和名称。
    • 单击 [image] 按钮打开另存为对话框。 在另存为对话框上输入文件名称，选择文件类型和文件存储位置。 然后单击确定按钮。 目标文件字段显示路径和文件名。
  6. 在导出文件对话框上单击确定按钮。

相关主题

导出和上载选项

导入和导出格式

导出数据字典文件(.ddf)


导出和上载选项

用这些选项将数据发送到另一个应用程序或工地设备上。 可在导出文件对话框上使用它们。

选项
源文件 | 选择或输入要导出的文件的路径，或者单击 [image] 图标找到另一个目录。
导出到文件 | 选择此选项将源文件导出到计算机或网络上的另一个文件位置。
上载到设备 | 选择此选项将文件发送到一台工地设备上。
文件类型 | 选择要导出的文件格式。
目标文件 | 选择或输入文件导出路径，或者单击 [image] 图标找到另一个目录。
设备名称 | 此字段显示你连接的工地设备的名称。
应用程序 | 选择要处理该文件的软件。

相关主题

导出和上载要素定义数据

导入和导出格式

导出数据字典文件(.ddf)


导出数据字典文件(.ddf)

如使用Trimble GPS Pathfinder软件，可以将数据词典文件(.ddf)导出到数据词典编辑器。 如用此格式导出要素数据，你不必在数据词典编辑器里重新创建属性。

  • 文件里的所有要素定义均被导出到数据词典文件里，无论你选择了哪些要素。 导出要素定义，无论它们是否包含属性。
  • 要素定义作为点要素导出。 可以在数据词典编辑器里将要素类型更改为直线。
  • 数据词典文件只包含要素名称、代码和属性。 不导出其他要素信息，例如图层、线型、组或控制代码。

相关主题

导出和上载要素定义数据

导出和上载选项

导入和导出格式


查看报告

可以查看多种报告。 如要查看报告，选择文件>报告，然后选择要查看的报告。 用独立的浏览器窗口打开报告。


Previous Topic

Next Topic

法律告示


公司联系资料

Trimble Navigation Limited
工程建筑事业部
5475 Kellenburger Road
Dayton, Ohio 45424-1099
U.S.A.

电话：+1-937-233-8921
免费电话：+1-800-538-7800
传真：+1-937-233-9441

www.trimble.com

版权和商标

Copyright 2006-2011, Trimble Navigation Limited. 版权所有。

地球三角标志和Trimble是Trimble Navigation Limited在美国专利与商标局和其他国家注册的商标。 Digital Fieldbook和Trimble Geomatics Office是Trimble Navigation Limited的商标。 Interlock和Recon是Trimble Navigation Limited的全资子公司Tripod Data Systems, Inc.的商标。 Microsoft和Windows是Microsoft Corporation在美国和/或其他国家的注册商标或商标。 其他所有商标是各自所有者的财产。

版本说明

这是Trimble Feature Definition Manager v2.08软件的帮助。